summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-06-25 07:43:01 +0000
committerYixun Lan <dlan@gentoo.org>2024-06-25 07:52:29 +0000
commit9297e0d6a09441a5964ffad2682f9efe1b5ac9d2 (patch)
tree3385d425777451827e5bafca3d777fa687ef0466 /app-i18n
parentdev-python/weasyprint: enable py3.13 (diff)
downloadgentoo-9297e0d6a09441a5964ffad2682f9efe1b5ac9d2.tar.gz
gentoo-9297e0d6a09441a5964ffad2682f9efe1b5ac9d2.tar.bz2
gentoo-9297e0d6a09441a5964ffad2682f9efe1b5ac9d2.zip
app-i18n/ibus-pinyin: add 1.5.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-pinyin/Manifest1
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.5.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-i18n/ibus-pinyin/Manifest b/app-i18n/ibus-pinyin/Manifest
index b02059bc483c..0e5353911d0c 100644
--- a/app-i18n/ibus-pinyin/Manifest
+++ b/app-i18n/ibus-pinyin/Manifest
@@ -1 +1,2 @@
DIST ibus-pinyin-1.5.0.tar.gz 692516 BLAKE2B ae53eb79ea4e5336347d689814d8ef033551a9b432268e643927b28911da3d03701acb3f337d7781168461c1c53537f2271fc8f253d1e99a269f61ae5eb83b05 SHA512 b0cd849ee3154543747dde8994eec9aed01d67e0d9be308a2f0230cf22f0281cd8fcabd9763b24238547a37e54400bcd8e541937767b93f005d04302f0c00241
+DIST ibus-pinyin-1.5.1.gh.tar.gz 241963 BLAKE2B 4f7a08c20a311e0dc76bbea87439976a4a26c01fb80be880f3f8ba7fdd9c309011b0cc9bbb63030e6f4e1f0866d4fad8d3324464160ca73ce663e272a042e0eb SHA512 2ad3e7705d3f537135576ceb165a305728739ba2965d8d50f6db8c5043f17f722ca8b42de053cdcb8ff05ef10a7f7c4a0c7f0924beefdfa197225e360c98abd9
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.1.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.1.ebuild
new file mode 100644
index 000000000000..11b12c65352d
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2008-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+LUA_COMPAT=( lua5-1 )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools lua-single python-single-r1
+
+DESCRIPTION="Chinese Pinyin and Bopomofo engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus-pinyin"
+SRC_URI="https://github.com/ibus/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/pyzy
+ dev-db/sqlite:3
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ boost? ( dev-libs/boost )
+ lua? ( ${LUA_DEPS} )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-build/autoconf-archive
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable nls)
+}