summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-03-15 20:40:04 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-03-15 20:41:13 +0100
commit929d24a4fecfb656207b046ed00522fc0d3f9cdc (patch)
tree27b56180a9f1d3a1a1e29b6025a25d9f7f78abfd /app-text
parentdev-scheme/guile: port 1.8 to EAPI 8 (diff)
downloadgentoo-929d24a4fecfb656207b046ed00522fc0d3f9cdc.tar.gz
gentoo-929d24a4fecfb656207b046ed00522fc0d3f9cdc.tar.bz2
gentoo-929d24a4fecfb656207b046ed00522fc0d3f9cdc.zip
app-text/kramdown-rfc2629: add 1.6.5
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kramdown-rfc2629/Manifest1
-rw-r--r--app-text/kramdown-rfc2629/kramdown-rfc2629-1.6.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-text/kramdown-rfc2629/Manifest b/app-text/kramdown-rfc2629/Manifest
index c505aa922c16..8af6765a4c1f 100644
--- a/app-text/kramdown-rfc2629/Manifest
+++ b/app-text/kramdown-rfc2629/Manifest
@@ -1,2 +1,3 @@
DIST kramdown-rfc2629-1.5.24.gem 51712 BLAKE2B bedca34835233e6db72b52ed634f07efa97a121903097230c95cc8db60c14662f697a5e02df5b87d8f2fa8614ac5bbc22d0a018d5dd339229da14c3517897c0e SHA512 6e358ad09afef4768e9c1698732c2058040f05180a8fda36c96dbbc68e670c8bf509ebdd92f51d9696b5305fb54398885230daa09b82ac5805a5c4d4eb10a4ba
DIST kramdown-rfc2629-1.5.26.gem 53248 BLAKE2B 2df5ae9715afd09ee2388280838687d4dc4694a9d2c309847c56986afe86b53a4bb4fdbdc0805f8bb2811fbce502b837d60ce96ff18d9b51b2e6ffc62ba6b65c SHA512 978d216d8ff4df309dad6408fbc5164c65e4a0a857d0e4599bdfe9763f68af7c3ea0a90827ef4f5d3102d3972d4cae85673aeac4f6cdd510fd3fa6ed6756b1b6
+DIST kramdown-rfc2629-1.6.5.gem 54784 BLAKE2B bc51d59303f4537881cf2af54167bec64b5760d11725582444a169bd05d34ed3a43ec8d3e412d8da725f3180cdeb502901bea9eb910e1d5d1590e16c1f701385 SHA512 a7c202770b699c2d06236418d54df1a52d6918c2c53b18d18a8988a274cf216e1c949777274b1f10ec7905ad5467678b209f420c365caf513422ff95d43fae6f
diff --git a/app-text/kramdown-rfc2629/kramdown-rfc2629-1.6.5.ebuild b/app-text/kramdown-rfc2629/kramdown-rfc2629-1.6.5.ebuild
new file mode 100644
index 000000000000..ea795b2d7efc
--- /dev/null
+++ b/app-text/kramdown-rfc2629/kramdown-rfc2629-1.6.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An XML2RFC (RFC799x) backend for Thomas Leitner's kramdown markdown parser"
+HOMEPAGE="https://github.com/cabo/kramdown-rfc"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ >=dev-ruby/certified-1.0.0
+ >=dev-ruby/json-2.0.0
+ >=dev-ruby/kramdown-2.3.0
+ >=dev-ruby/kramdown-parser-gfm-1.1.0
+"
+
+all_ruby_prepare() {
+ sed -i 's/json_pure/json/' ../metadata || die
+}