summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/japitools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/japitools')
-rw-r--r--dev-java/japitools/Manifest1
-rw-r--r--dev-java/japitools/files/japitools-0.9.7-classpath.patch20
-rw-r--r--dev-java/japitools/japitools-0.9.7-r1.ebuild56
-rw-r--r--dev-java/japitools/metadata.xml13
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-java/japitools/Manifest b/dev-java/japitools/Manifest
new file mode 100644
index 000000000000..6802615e3949
--- /dev/null
+++ b/dev-java/japitools/Manifest
@@ -0,0 +1 @@
+DIST japitools-0.9.7.tar.gz 92537 SHA256 2201fe0252713938e70bdf0fc118c640477d8b9fc0ad2967734f4b8ee1630b80 SHA512 28e2ecb76d8b180134904ec7aef5b15c60b02be32ef2519886eb38bb468f80ab59abb7ce27752ddbd380a3ef580e8435a983cc17797f3147933894786fd8e52d WHIRLPOOL f59aa416e5f53364d949a3549cb8a93723ff869becb95a44eaedbe47ffed94b6c1d4310f4efe91e0108a5bb40baca674d537ab3c8552d96e036cfb770897fc2d
diff --git a/dev-java/japitools/files/japitools-0.9.7-classpath.patch b/dev-java/japitools/files/japitools-0.9.7-classpath.patch
new file mode 100644
index 000000000000..caf3f1a7f296
--- /dev/null
+++ b/dev-java/japitools/files/japitools-0.9.7-classpath.patch
@@ -0,0 +1,20 @@
+diff -Nur japitools-0.9.7/src/net/wuffies/japi/JapiantTask.java japitools-0.9.7_patched/src/net/wuffies/japi/JapiantTask.java
+--- japitools-0.9.7/src/net/wuffies/japi/JapiantTask.java 2006-10-23 02:42:44.000000000 +0300
++++ japitools-0.9.7_patched/src/net/wuffies/japi/JapiantTask.java 2008-07-03 20:46:59.000000000 +0300
+@@ -130,7 +130,15 @@
+ }
+
+ {
+- args.add(System.getProperty("java.home") + File.separator + "lib" + File.separator + "rt.jar");
++ File rtJar=new File(System.getProperty("java.home") + File.separator + "lib" + File.separator + "rt.jar");
++ if(rtJar.exists())
++ args.add(System.getProperty("java.home") + File.separator + "lib" + File.separator + "rt.jar");
++ File vmJar=new File(System.getProperty("java.home") + File.separator + "lib" + File.separator + "vm.jar");
++ if(vmJar.exists())
++ args.add(System.getProperty("java.home") + File.separator + "lib" + File.separator + "vm.jar");
++ File coreJar=new File(System.getProperty("java.home") + File.separator + "lib" + File.separator + "core.jar");
++ if(coreJar.exists())
++ args.add(System.getProperty("java.home") + File.separator + "lib" + File.separator + "core.jar");
+ }
+
+ {
diff --git a/dev-java/japitools/japitools-0.9.7-r1.ebuild b/dev-java/japitools/japitools-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..96ddbfd5c3b5
--- /dev/null
+++ b/dev-java/japitools/japitools-0.9.7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source test"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java API compatibility testing tools"
+HOMEPAGE="http://sab39.netreach.com/japi/"
+
+SRC_URI="http://www.kaffe.org/~stuart/japi/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-java/ant-core
+ >=virtual/jdk-1.4
+ test? (
+ =dev-java/junit-3*
+ dev-java/ant-junit
+ )"
+
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-classpath.patch
+
+ cd "${S}"/bin || die
+ rm japize.bat || die
+ sed -e "s:../share/java:../share/${PN}/lib:" -i * \
+ || die "Failed to correct the location of the jar file in perl scripts."
+}
+
+src_compile() {
+ eant jar
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}
+src_install() {
+ java-pkg_dojar share/java/*.jar
+ dobin bin/*
+
+ if use doc; then
+ cp -r design "${T}"
+ dohtml "${T}"/design/{*.css,*.html}
+ rm "${T}"/design/{*.css,*.html}
+ dodoc "${T}"/design/*
+ fi
+
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/japitools/metadata.xml b/dev-java/japitools/metadata.xml
new file mode 100644
index 000000000000..8759b6fb051b
--- /dev/null
+++ b/dev-java/japitools/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+Japitools consists of two simple tools designed to test for compatibility
+between Java APIs. They were originally designed for testing free implementations
+of Java itself for compatibility with Sun's JDK, but they can also be used for
+testing backward compatibility between versions of any API.
+</longdescription>
+
+</pkgmetadata>