summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/go-fuse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/go-fuse')
-rw-r--r--dev-libs/go-fuse/Manifest2
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild52
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20150422.ebuild52
-rw-r--r--dev-libs/go-fuse/go-fuse-9999.ebuild56
-rw-r--r--dev-libs/go-fuse/metadata.xml13
5 files changed, 175 insertions, 0 deletions
diff --git a/dev-libs/go-fuse/Manifest b/dev-libs/go-fuse/Manifest
new file mode 100644
index 000000000000..eb3ffdd413ce
--- /dev/null
+++ b/dev-libs/go-fuse/Manifest
@@ -0,0 +1,2 @@
+DIST go-fuse-0_p20140812.tar.gz 111389 SHA256 183f477e02822528693ea824680a79f44b14a4491b10d1738658d71a32e6faf3 SHA512 d951094e290bc914b418c165106368d6b73634ffb177b770ce53baaca4cd6026967f11d602b3e687e59a49323c7af1af74913ec1a911093e4e32503025842cb3 WHIRLPOOL 067eb869634d52ade241113c2c4827ad2266c7d192bc1d89a052e8bbcea699a51c4d0917cea4d93d12185fe55381341a4363a9cc689ed8df90abcd79679c632e
+DIST go-fuse-0_p20150422.tar.gz 110741 SHA256 825edaff6e65a9bc0e1fb52fe1791826f4f17a37e4373bcbde99d15dfb63723d SHA512 a0c9fa666ab39632db258baa5bf6ba1546aa847beb0d4a4b812a96e66d8573e3c0a0600ad24e16e314fbd8082b36027a3e1bc2092667766f611b1321aaea70c5 WHIRLPOOL ec33dfb773f5cff79e8f6c3acded538a68853035d197c689971f9b857244245039ced14a1ef970c1b14b5b6d2419fae7b6193b038d7245da119aee068677c0f6
diff --git a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
new file mode 100644
index 000000000000..eb4bbe604de0
--- /dev/null
+++ b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+RESTRICT="strip"
+DESCRIPTION="FUSE bindings for Go"
+GO_PN=github.com/hanwen/${PN}
+HOMEPAGE="https://${GO_PN}"
+EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.3"
+RDEPEND=""
+S=${WORKDIR}
+
+src_unpack() {
+ default_src_unpack
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_prepare() {
+ sed -e "s:\(go \${target}\)\(.*\)$:\\1 -x \\2:" \
+ -e 's:^for target in "clean" "install" ; do$:for target in "install" ; do:' \
+ -e '17,26d' \
+ src/${GO_PN}/all.bash > src/${GO_PN}/all.bash.patched || die
+}
+
+src_compile() {
+ # Create a filtered GOROOT tree out of symlinks,
+ # excluding go-fuse, for bug #503324.
+ cp -sR /usr/lib/go goroot || die
+ rm -rf goroot/src/${GO_PN} || die
+ rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
+ CGO_CFLAGS="${CFLAGS}" GOROOT="${WORKDIR}/goroot" GOPATH="${WORKDIR}" \
+ bash src/${GO_PN}/all.bash.patched || die
+}
+
+src_install() {
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go
+ doins -r pkg
+ insinto /usr/lib/go/src
+ rm src/${GO_PN}/all.bash.patched || die
+ find src/${GO_PN} -name .gitignore -delete
+ doins -r src/*
+}
diff --git a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
new file mode 100644
index 000000000000..839de1e5a8a1
--- /dev/null
+++ b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+RESTRICT="strip"
+DESCRIPTION="FUSE bindings for Go"
+GO_PN=github.com/hanwen/${PN}
+HOMEPAGE="https://${GO_PN}"
+EGIT_COMMIT="ffed29ec8b88f61c1b8954134cc48ef03bb26ce1"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.3"
+RDEPEND=""
+
+src_unpack() {
+ default_src_unpack
+ mkdir -p "${S}/src/${GO_PN%/*}" || die
+ mv ${PN}-${EGIT_COMMIT} "${S}/src/${GO_PN}" || die
+ find "${S}" -name .gitignore -delete || die
+}
+
+call_go() {
+ local d
+ for d in fuse fuse/pathfs zipfs unionfs; do
+ GOROOT="${GOROOT}" GOPATH="${S}" \
+ go "${1}" -v -x -work ${GO_PN}/${d} || die
+ done
+}
+
+src_compile() {
+ # Create a filtered GOROOT tree out of symlinks,
+ # excluding go-fuse, for bug #503324.
+ GOROOT="${WORKDIR}/goroot"
+ cp -sR /usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN}" || die
+ rm -rf "${GOROOT}/pkg/linux_${ARCH}/${GO_PN}" || die
+ call_go build
+}
+
+src_install() {
+ call_go install
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go
+ doins -r pkg src
+}
diff --git a/dev-libs/go-fuse/go-fuse-9999.ebuild b/dev-libs/go-fuse/go-fuse-9999.ebuild
new file mode 100644
index 000000000000..f3e190c01d4c
--- /dev/null
+++ b/dev-libs/go-fuse/go-fuse-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-r3
+
+RESTRICT="strip"
+
+DESCRIPTION="native bindings for the FUSE kernel module"
+HOMEPAGE="https://github.com/hanwen/go-fuse"
+EGIT_REPO_URI="https://github.com/hanwen/go-fuse.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.3"
+RDEPEND=""
+
+GO_PN="github.com/hanwen/${PN}"
+EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
+
+export GOPATH="${S}"
+
+src_compile() {
+#no examples right now
+# example/hello example/loopback example/zipfs \
+# example/multizip example/unionfs example/memfs \
+# example/autounionfs ; \
+#or tests
+#fuse/test
+for d in fuse fuse/pathfs zipfs unionfs
+do
+ go build -v -x -work ${GO_PN}/${d} || die
+done
+}
+
+src_install() {
+for d in fuse fuse/pathfs zipfs unionfs
+do
+ go install -v -x -work ${GO_PN}/${d} || die
+done
+
+insinto /usr/lib/go/
+doins -r "${S}/pkg"
+insinto "/usr/lib/go/src/${GO_PN}/"
+#for this ebuild, to fix bug #503324 I have limited what is installed
+#another possible solution would have been using adddeny to the
+#hide installed filed during build
+rm -r "${S}/src/${GO_PN}/.git"
+doins -r "${S}/src/${GO_PN}/fuse"
+doins -r "${S}/src/${GO_PN}/splice"
+}
diff --git a/dev-libs/go-fuse/metadata.xml b/dev-libs/go-fuse/metadata.xml
new file mode 100644
index 000000000000..f491ba214d1a
--- /dev/null
+++ b/dev-libs/go-fuse/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">hanwen/go-fuse</remote-id>
+ </upstream>
+</pkgmetadata>