summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-22 20:28:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-22 22:10:59 +0200
commit4cd17c2a4a7d06943b6073929c937c0c92c23f24 (patch)
tree40e1ab70610615629f6d357fb3d7744f3a0c1e11 /dev-libs/kopeninghours
parentapp-office/kalendar: 22.08.0 version bump (diff)
downloadgentoo-4cd17c2a4a7d06943b6073929c937c0c92c23f24.tar.gz
gentoo-4cd17c2a4a7d06943b6073929c937c0c92c23f24.tar.bz2
gentoo-4cd17c2a4a7d06943b6073929c937c0c92c23f24.zip
dev-libs/kopeninghours: 22.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-22.08.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 57c3858d5ff5..05e6bc7a411d 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-22.04.3.tar.xz 69160 BLAKE2B 8875d1ee869c6cae8730e83ff8144e45a6ab24aff02ec85084022ab30f9274a2f7c5bd4e0bf88f27c3626ee580a6fac9e2446fa711823011b305ba9bdf1d88c9 SHA512 68e49cd35db2f381cfd88787ed2085e69c6485de87c2cd5783675784cb169d274115d9bc36cde6ed447d6cff6922278330ac1aa819a0d996f2a5b861f6f1bf7e
+DIST kopeninghours-22.08.0.tar.xz 70136 BLAKE2B cc5b2f97a65487f97f702a86ec1ff3f7969cb7955b92280598a5ad04e6c225b0976c8b7e2a6122171917600100985b4292005467806fe6af1cbc8ffb17a0ef44 SHA512 436251958f0139a79dba0ea66db13265697aa0aa11c1da05ea8243ef61bdb34a134422214ec50fbed98f0f38c1f32f5196f1641cc358e2cccd9359978e3fce05
diff --git a/dev-libs/kopeninghours/kopeninghours-22.08.0.ebuild b/dev-libs/kopeninghours/kopeninghours-22.08.0.ebuild
new file mode 100644
index 000000000000..90195ba42ded
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-22.08.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+PYTHON_COMPAT=( python3_{8..11} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}