summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-09 05:45:12 +0000
committerSam James <sam@gentoo.org>2023-03-09 05:58:27 +0000
commitb903d44b14b0d4a66e0f65f91022f40e55f1ad50 (patch)
tree580192465b40ba28d625c8e646017492644549d9 /dev-libs
parentsys-libs/ldb: add 2.7.1 (diff)
downloadgentoo-b903d44b14b0d4a66e0f65f91022f40e55f1ad50.tar.gz
gentoo-b903d44b14b0d4a66e0f65f91022f40e55f1ad50.tar.bz2
gentoo-b903d44b14b0d4a66e0f65f91022f40e55f1ad50.zip
dev-libs/librelp: enable py3.11, drop -Werror, workaround bashism
Closes: https://bugs.gentoo.org/896724 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/librelp/librelp-1.10.0-r1.ebuild (renamed from dev-libs/librelp/librelp-1.10.0.ebuild)23
1 files changed, 12 insertions, 11 deletions
diff --git a/dev-libs/librelp/librelp-1.10.0.ebuild b/dev-libs/librelp/librelp-1.10.0-r1.ebuild
index c277894327aa..5aac6f9418b9 100644
--- a/dev-libs/librelp/librelp-1.10.0.ebuild
+++ b/dev-libs/librelp/librelp-1.10.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit autotools python-any-r1
DESCRIPTION="An easy to use library for the RELP protocol"
@@ -11,24 +11,24 @@ HOMEPAGE="https://www.rsyslog.com/librelp/"
SRC_URI="https://download.rsyslog.com/${PN}/${P}.tar.gz"
LICENSE="GPL-3+ doc? ( FDL-1.3 )"
-
# subslot = soname version
SLOT="0/0.5.1"
-
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc64 ~riscv sparc x86"
IUSE="debug doc +ssl +gnutls openssl static-libs test"
REQUIRED_USE="ssl? ( ^^ ( gnutls openssl ) )"
+RESTRICT="!test? ( test )"
RDEPEND="
ssl? (
- gnutls? ( >=net-libs/gnutls-3.3.17.1:0= )
- openssl? ( dev-libs/openssl:0= )
- )"
-DEPEND="${RDEPEND}
+ gnutls? ( >=net-libs/gnutls-3.3.17.1:= )
+ openssl? ( dev-libs/openssl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
test? ( ${PYTHON_DEPS} )
- virtual/pkgconfig"
-
-RESTRICT="!test? ( test )"
+"
+BDEPEND="virtual/pkgconfig"
pkg_setup() {
use test && python-any-r1_pkg_setup
@@ -47,13 +47,14 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--disable-valgrind
+ --disable-Werror
$(use_enable debug)
$(use_enable gnutls tls)
$(use_enable openssl tls-openssl)
$(use_enable static-libs static)
)
- econf "${myeconfargs[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
}
src_test() {