summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:28:21 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:45 +0100
commitc86e23fc16e00c4b37c117c6437b9a96ccc73197 (patch)
tree2421c8622708e57927993863e1f0cafef4d424bf /dev-lua/luaevent
parentdev-lua/luadbi: drop 0.7.2-r103 (diff)
downloadgentoo-c86e23fc16e00c4b37c117c6437b9a96ccc73197.tar.gz
gentoo-c86e23fc16e00c4b37c117c6437b9a96ccc73197.tar.bz2
gentoo-c86e23fc16e00c4b37c117c6437b9a96ccc73197.zip
dev-lua/luaevent: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luaevent')
-rw-r--r--dev-lua/luaevent/luaevent-0.4.6-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-lua/luaevent/luaevent-0.4.6-r1.ebuild b/dev-lua/luaevent/luaevent-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..8088a451e565
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.6-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Binding of libevent for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent"
+SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/libevent:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ local mysedargs=(
+ -e "'s/CFLAGS =/CFLAGS +=/'"
+ -e "'s/LDFLAGS =/LDFLAGS +=/'"
+ -e "'s:-I\$(LUA_INC_DIR):\$(LUA_INC_DIR):'"
+ -i Makefile
+ )
+
+ eval sed ${mysedargs[@]} || die
+}
+
+lua_src_compile() {
+ tc-export CC
+
+ emake LUA_INC_DIR="$(lua_get_CFLAGS)"
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ local myemakeargs=(
+ DESTDIR="${ED}"
+ INSTALL_DIR_BIN="$(lua_get_cmod_dir)"
+ INSTALL_DIR_LUA="$(lua_get_lmod_dir)"
+ LUA_INC_DIR="$(lua_get_CFLAGS)"
+ )
+
+ emake ${myemakeargs[@]} install
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}