summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-27 16:58:21 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-27 17:40:26 +0200
commit1fdf294e583c459fba3318e188b41ab969758133 (patch)
tree67bfae9d77c119210397114cb43030bcb0ace35c /dev-lua
parentdev-lua/luacheck: stable all-arches (diff)
downloadgentoo-1fdf294e583c459fba3318e188b41ab969758133.tar.gz
gentoo-1fdf294e583c459fba3318e188b41ab969758133.tar.bz2
gentoo-1fdf294e583c459fba3318e188b41ab969758133.zip
dev-lua/luacheck: drop 1.1.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luacheck/Manifest1
-rw-r--r--dev-lua/luacheck/luacheck-1.1.2.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-lua/luacheck/Manifest b/dev-lua/luacheck/Manifest
index e8199aa650b6..41aaef789053 100644
--- a/dev-lua/luacheck/Manifest
+++ b/dev-lua/luacheck/Manifest
@@ -1,2 +1 @@
-DIST luacheck-1.1.2.tar.gz 179240 BLAKE2B 52fdf895e14ec42f86078c9a0be3adc91b0d51c525281ec19cc41671437ca2a29a79c1a826026de11b433368b306ddf2b21473b90975d1de1c13b160d208a25b SHA512 38b22cc0fd00905572859092c4138081c5be434b6e3314bc6cee14b859b0fa1dbb078c6474588891ec3e75b378a7be9a09ee164a4ef9291378193f3bdda10365
DIST luacheck-1.2.0.tar.gz 183209 BLAKE2B 5c1260d87c523a2094071c674a71dce362be5ad65ca52094564b93d02c6ef7e662631769cbdbafe9c0cb4d2bcb61c5e46cbbc1a8fc9ed287043aafc2ebae9c90 SHA512 2bfe38056bab71cdaa8377212cc92048e3178f2deb1da8d61b9cefc400a9b5691772805f8bc1c4b4584c9530751103a2feeca41187c2d9496e975df5be373ff0
diff --git a/dev-lua/luacheck/luacheck-1.1.2.ebuild b/dev-lua/luacheck/luacheck-1.1.2.ebuild
deleted file mode 100644
index e7f6b7200caa..000000000000
--- a/dev-lua/luacheck/luacheck-1.1.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua
-
-DESCRIPTION="A tool for linting and static analysis of Lua code"
-HOMEPAGE="https://github.com/lunarmodules/luacheck"
-SRC_URI="https://github.com/lunarmodules/luacheck/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/lua-argparse[${LUA_USEDEP}]
- dev-lua/lua-utf8[${LUA_USEDEP}]
- dev-lua/luafilesystem[${LUA_USEDEP}]
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- fi
-}
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto "$(lua_get_lmod_dir)"
- doins -r src/luacheck
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- newbin bin/luacheck.lua luacheck
-
- use doc && local -a HTML_DOCS=( "html/." )
- einstalldocs
-}