summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-19 09:57:00 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-19 09:57:23 +0100
commite51b599a1c8d7f931c5e9862c21301b2b23f5c6c (patch)
tree27cf9a9db5eeba90bd5dc9220e2ae2e67d82af97 /dev-ml/pcre-ocaml
parentsci-libs/branca: enable py3.11 (diff)
downloadgentoo-e51b599a1c8d7f931c5e9862c21301b2b23f5c6c.tar.gz
gentoo-e51b599a1c8d7f931c5e9862c21301b2b23f5c6c.tar.bz2
gentoo-e51b599a1c8d7f931c5e9862c21301b2b23f5c6c.zip
dev-ml/pcre-ocaml: add 7.5.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/Manifest1
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/Manifest b/dev-ml/pcre-ocaml/Manifest
index 18cda75caeaa..4a367867e66e 100644
--- a/dev-ml/pcre-ocaml/Manifest
+++ b/dev-ml/pcre-ocaml/Manifest
@@ -1 +1,2 @@
DIST pcre-ocaml-7.4.6.tbz 41027 BLAKE2B 1faecd96cb6f7af248e8ace7409a49131f5c654320f8ac432fd4aff602d0c4187733419e9cc73ca52cf0a3e5b725afa9357fe9ec191bf1ca42d4dc47a36e45b7 SHA512 a356c78dc19d3b3741d1fa0277c4fb0cb545f12499165526fae80a0ff8a7b1f1e6e5e916b16f8336bcec3661de811686b814fe4afc677965fec7a63d4fc53b1f
+DIST pcre-ocaml-7.5.0.tbz 41158 BLAKE2B 6bd16345bd915c236d727daeb5862c2aff677c394f10b4d040ce46003255f3fd5589801979cdd77c20d8ba4fceb443467cf8f38a379a86fc59ca513e69aa1b79 SHA512 be60f13ddb6bbfe20e30ca5d92434d85e1d1371479e1e2c725588af83fcc9366ed0435021b6a800c20336ac521f2134c767420136438684656a44ac1f9924be4
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
new file mode 100644
index 000000000000..8351c029f26d
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/${PV}/pcre-${PV}.tbz -> ${P}.tbz"
+S="${WORKDIR}/pcre-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples +ocamlopt"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+
+BDEPEND="dev-ml/dune-configurator"
+RDEPEND=">=dev-libs/libpcre-4.5
+ dev-ml/stdio:=
+ >=dev-lang/ocaml-4.12"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune_src_install pcre
+
+ if use examples ; then
+ dodoc -r examples
+ fi
+}