summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:43:00 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:43:00 +0200
commit23c0a3b74e5dadbf05846094d32067bfc404055d (patch)
treefb659ef00d3f53613f1768534f62df4b0c98413b /dev-python/csvkit
parentdev-python/versioneer: add 0.22 (diff)
downloadgentoo-23c0a3b74e5dadbf05846094d32067bfc404055d.tar.gz
gentoo-23c0a3b74e5dadbf05846094d32067bfc404055d.tar.bz2
gentoo-23c0a3b74e5dadbf05846094d32067bfc404055d.zip
dev-python/csvkit: add 1.0.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/csvkit')
-rw-r--r--dev-python/csvkit/Manifest1
-rw-r--r--dev-python/csvkit/csvkit-1.0.7.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/csvkit/Manifest b/dev-python/csvkit/Manifest
index aef8d69341e5..c20e1de8a206 100644
--- a/dev-python/csvkit/Manifest
+++ b/dev-python/csvkit/Manifest
@@ -1 +1,2 @@
DIST csvkit-1.0.6.tar.gz 3784737 BLAKE2B b1e4583443cbfc62f713d3b311bbe313cf4e69b7aa5aa13dc6970375a727a804ba1dbd176b25487027d3bc1a5696f2ce649a460c91ef7c5591c33bb3c6f48c33 SHA512 fb37404405f2f2c0bf803a1df8186aa9e3b11cbf3c4f6e1fe6dc06d53730aa91d462bebcca3917e9a451f1d81df053abd9ceedfaab085ab696f9ba701c873323
+DIST csvkit-1.0.7.tar.gz 3792335 BLAKE2B 6a9c5c1287648271eacf5f010a4b181f5e997a52d196ac4b73b95723e5ce2a3d90d0b51fe4f597b0b346292cefc16b7c283b02e9a8e56f26e10bca9b3f8622ea SHA512 c6275ed000639a1ddf15246eb1e0198787f832537a284900067e3ec65986be115709b3fd4aaf8e13a9b53160edd57ebb864ee1e73354712591c78297b6d293b7
diff --git a/dev-python/csvkit/csvkit-1.0.7.ebuild b/dev-python/csvkit/csvkit-1.0.7.ebuild
new file mode 100644
index 000000000000..0331290b2991
--- /dev/null
+++ b/dev-python/csvkit/csvkit-1.0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A suite of utilities for converting to and working with CSV"
+HOMEPAGE="https://github.com/wireservice/csvkit https://pypi.org/project/csvkit/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/agate-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/agate-excel-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/agate-dbf-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/agate-sql-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_utilities/test_in2csv.py::TestIn2CSV::test_convert_dbf
+)