summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorneeshy <neeshy@tfwno.gf>2020-03-26 17:49:33 -0400
committerCraig Andrews <candrews@gentoo.org>2020-04-18 22:35:42 -0400
commita53604b275a4552ea8fcced6f20eba40f85a03b3 (patch)
treeb3389fbe7c406f0455077face20b4f84dc3891ba /dev-python/fs
parentdev-python/fonttools: add python3_8 target (diff)
downloadgentoo-a53604b275a4552ea8fcced6f20eba40f85a03b3.tar.gz
gentoo-a53604b275a4552ea8fcced6f20eba40f85a03b3.tar.bz2
gentoo-a53604b275a4552ea8fcced6f20eba40f85a03b3.zip
dev-python/fs: add python3_8 target
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf> Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.9-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/fs/fs-2.4.9-r1.ebuild b/dev-python/fs/fs-2.4.9-r1.ebuild
new file mode 100644
index 000000000000..7bc6c8c04459
--- /dev/null
+++ b/dev-python/fs/fs-2.4.9-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ https://pypi.org/project/fs/
+ https://docs.pyfilesystem.org
+ https://www.willmcgugan.com/tag/fs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/pysendfile[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ ' -3)
+)"
+
+python_test() {
+ # python2_7 tests require dev-python/typing which is
+ # now in stdlib so ignore tests. py2.7 is going away.
+ if python_is_python3; then
+ esetup.py test || die "tests failed"
+ fi
+}
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}