summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-28 10:17:24 +0100
committerSam James <sam@gentoo.org>2023-07-28 10:31:20 +0100
commita2c830098c53be97bf1907b2f603e5a21dadefac (patch)
treef7ee5fa0b645c2617c03db1a5482e9486e00d2c0 /dev-python/llfuse
parentdev-python/poetry: Add missing lockfile dep too (diff)
downloadgentoo-a2c830098c53be97bf1907b2f603e5a21dadefac.tar.gz
gentoo-a2c830098c53be97bf1907b2f603e5a21dadefac.tar.bz2
gentoo-a2c830098c53be97bf1907b2f603e5a21dadefac.zip
dev-python/llfuse: depend on <cython-3
Bug: https://bugs.gentoo.org/911373 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/files/llfuse-1.4.4-cython3.patch42
-rw-r--r--dev-python/llfuse/llfuse-1.4.4.ebuild4
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/llfuse/files/llfuse-1.4.4-cython3.patch b/dev-python/llfuse/files/llfuse-1.4.4-cython3.patch
new file mode 100644
index 000000000000..38fea36a5fac
--- /dev/null
+++ b/dev-python/llfuse/files/llfuse-1.4.4-cython3.patch
@@ -0,0 +1,42 @@
+https://github.com/python-llfuse/python-llfuse/commit/8c0160545ce01b3624c8ecad669f06fb6d22d2f6
+
+From 8c0160545ce01b3624c8ecad669f06fb6d22d2f6 Mon Sep 17 00:00:00 2001
+From: Thomas Waldmann <tw@waldmann-edv.de>
+Date: Sun, 21 May 2023 01:31:38 +0200
+Subject: [PATCH] remove Cython version check, fixes #81
+
+distutils Version classes are deprecated.
+
+I decided to remove the Cython version check completely,
+it is not as simple as checking a minimum version anyway.
+
+E.g. we can work with Cython 0.29.x and also 3.0.0b2,
+but earlier 3.0.0 releases are of unknown compatibility.
+
+Also, latest Python 3.12-dev versions require 0.29.34,
+while older Pythons are happy with stuff compiled by earlier
+0.29.x releases.
+--- a/setup.py
++++ b/setup.py
+@@ -34,7 +34,6 @@
+
+ import setuptools
+ from setuptools import Extension
+-from distutils.version import LooseVersion
+
+ basedir = os.path.abspath(os.path.dirname(__file__))
+ sys.path.insert(0, os.path.join(basedir, 'util'))
+@@ -218,11 +217,7 @@ def run(self):
+ stderr=subprocess.STDOUT)
+ except OSError:
+ raise SystemExit('Cython needs to be installed for this command')
+-
+- hit = re.match('^Cython version (.+)$', version)
+- if not hit or LooseVersion(hit.group(1)) < "0.29":
+- # in fact, we need a very recent Cython version to support the latest pythons
+- raise SystemExit('Need Cython 0.29 or newer, found ' + version)
++ print(f"Using {version.strip()}.")
+
+ cmd = ['cython', '-Wextra', '--force', '-3', '--fast-fail',
+ '--directive', 'embedsignature=True', '--include-dir',
+
diff --git a/dev-python/llfuse/llfuse-1.4.4.ebuild b/dev-python/llfuse/llfuse-1.4.4.ebuild
index 6bcd11762ba5..f6edb91dd6d3 100644
--- a/dev-python/llfuse/llfuse-1.4.4.ebuild
+++ b/dev-python/llfuse/llfuse-1.4.4.ebuild
@@ -27,13 +27,15 @@ DEPEND="
${RDEPEND}
sys-apps/attr
"
+# <cython-3: bug #911373
BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
virtual/pkgconfig
"
PATCHES=(
"${FILESDIR}"/llfuse-1.3.5-cflags.patch
+ "${FILESDIR}"/llfuse-1.4.4-cython3.patch
)
distutils_enable_sphinx rst