summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-16 09:07:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-16 10:37:27 +0100
commit5b289bf334cac6bcdfdc16c6eb5d1ffb6f5cd5fa (patch)
tree3f1cd23db799682697ffd564f83426a1336a3cd0 /dev-python/nuitka
parentdev-python/nuitka: Remove old (diff)
downloadgentoo-5b289bf334cac6bcdfdc16c6eb5d1ffb6f5cd5fa.tar.gz
gentoo-5b289bf334cac6bcdfdc16c6eb5d1ffb6f5cd5fa.tar.bz2
gentoo-5b289bf334cac6bcdfdc16c6eb5d1ffb6f5cd5fa.zip
dev-python/nuitka: Bump to 0.6.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.19.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index d4864aec1404..fcaa22f84a68 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-0.6.19.1.tar.gz 3727050 BLAKE2B 70cde9f6c7254cc229dc534736c1445f9fc813a1463705e0116021107c6b6909c9ac1e35bf7b0b452cd6b6d23b2c4e4103e8427c44d6d3c3273f7f70ad5daeee SHA512 83c5a6c2c547f139cd947c804f646b37f0fbaaa44a53b1cc42366170f91de138d63b5eeb2fa2e37ba9a24cb34c1faeb8e86c09cb08e829aa6d3607931c2eebbf
+DIST Nuitka-0.6.19.2.tar.gz 3727729 BLAKE2B f74512ab2b57ab66b62e7a67fed8366971fe23103297ab5361685b19408445dac7335e3086f0ce236c7346bcf4d8dfcf828040412e4868e82f06c03e6ea52fd0 SHA512 a92b24168e16054399692d0984dd417b181d2bb920825eabaa64798933b481e188827b5bbae040d329e67b09002b21ce471ce1352b12ac46ab2b8fec97523aa5
DIST Nuitka-0.6.19.tar.gz 3739123 BLAKE2B c2e9a6417ff65927c3246849d614fdebb8bcf323b6496dae81f7cef3ab86a22ad21d3fe3eb19c74ea7f228310e3b1b985cea56201efe71c1b0d8ff64998973c0 SHA512 2d8f8c0d95f6d85c7969879ddbe2375ae190bfc1466a21c442e9e109ed7759ecf0bdcc2f29ec8fed5462df52e1b1e69a0e10574d8e7f52b1dfef7f7ae9626c75
diff --git a/dev-python/nuitka/nuitka-0.6.19.2.ebuild b/dev-python/nuitka/nuitka-0.6.19.2.ebuild
new file mode 100644
index 000000000000..f2d40b4c0565
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.19.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}