summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-24 21:20:34 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-24 21:38:26 -0700
commit0004ad37a9032385a5ff4a10851388166b77aac2 (patch)
tree83efaa9194581c916d47f1848d5f0827396cffce /dev-python/pyatspi
parentx11-libs/gtk+extra: Version bump to 3.3.4 (diff)
downloadgentoo-0004ad37a9032385a5ff4a10851388166b77aac2.tar.gz
gentoo-0004ad37a9032385a5ff4a10851388166b77aac2.tar.bz2
gentoo-0004ad37a9032385a5ff4a10851388166b77aac2.zip
dev-python/pyatspi: Version bump to 2.36.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest1
-rw-r--r--dev-python/pyatspi/pyatspi-2.36.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index 749dd6ca025a..d3814ee82047 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,2 +1,3 @@
DIST pyatspi-2.32.1.tar.xz 310896 BLAKE2B acf4a0211015daf5a19a796de9e267637ae77b2f79f0c6af20bfa5eb5a0fa0d4a62cf23524348299daebd515cccb7a4a1c18226e8c04356ea6439840613242a7 SHA512 6cdddc4275770a4f89e66355e18518f5cbf1ceeee1f27298be1fb5bb8b67676eeeb81ce7f4fbb5ad617573f574e5fd5858d363c77a0e5727d637ae7275429b03
DIST pyatspi-2.34.0.tar.xz 314060 BLAKE2B 1d2c390c6f110a37e9553b1f1aeba75fa0585beabddb2d6db54aa8fddc671b844e7c670c7fdf9696e3833c8f9619dc8a2ecc364019f14703647e7996033c7dd7 SHA512 61b157f067e23b7a964cf8268f556ad059982f448e436ecb25c96915ecb53918c6ab7b29bfb4e7b85e25e6038e27678fbd3d0bfb61d14a038ab5eaeee1f682b4
+DIST pyatspi-2.36.0.tar.xz 315076 BLAKE2B f3f92dafab68ce003e9d63f8ebf901ef834eafb1fab3ddd2051dcfb308b79d7ce6fc4d9187ed51f3af8bebad5e6ef2296c19215ee209ad37fe717f332af8d8f7 SHA512 709236fd992f570426043e32b201bdfee06bb28faa3d1237778f4069d3548b88b8336e53c0951359f5c7e2914b90f6f682ac58e33c84e32f360bdc32662800af
diff --git a/dev-python/pyatspi/pyatspi-2.36.0.ebuild b/dev-python/pyatspi/pyatspi-2.36.0.ebuild
new file mode 100644
index 000000000000..0b7083708f43
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.36.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python client bindings for D-Bus AT-SPI"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.34[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installing
+
+ docinto examples
+ dodoc examples/*.py
+}