summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-23 06:26:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-23 07:18:01 +0100
commiteb9d8f73582e9b35e6051a826c011f29c5600d20 (patch)
treecb94da32032065ec3378444a687dd6aa7ad69562 /dev-python/pylint-venv
parentdev-python/caldav: Bump to 1.1.3 (diff)
downloadgentoo-eb9d8f73582e9b35e6051a826c011f29c5600d20.tar.gz
gentoo-eb9d8f73582e9b35e6051a826c011f29c5600d20.tar.bz2
gentoo-eb9d8f73582e9b35e6051a826c011f29c5600d20.zip
dev-python/pylint-venv: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint-venv')
-rw-r--r--dev-python/pylint-venv/Manifest1
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/Manifest b/dev-python/pylint-venv/Manifest
index e923065b1a81..2fdd8d0ec82e 100644
--- a/dev-python/pylint-venv/Manifest
+++ b/dev-python/pylint-venv/Manifest
@@ -1 +1,2 @@
DIST pylint-venv-2.3.0.gh.tar.gz 4967 BLAKE2B 7095848b28f1128d44164fecbd1fd1c3694140d8b3818fefcab92aa5a4083608dfc36c96a6c30b117a8592bea0de9b92a537c33f8db4ce8c1285a575d1aa2131 SHA512 c3f9294a137cc6369984cf714196ee0a248471990f2c6e691da86f3048126b99775cc8e9c516c72bd8746d0d814a52387eca165c5f1960aa418ec5abb13a3bed
+DIST pylint-venv-3.0.0.gh.tar.gz 14757 BLAKE2B 807b0e6eb7fee32d592fc215a6c4018003078f66c3500ffb9e9769e98e2226554433f2ae33f6480ae4240e8e96b932df23f8ddc3b3dab5bdd54cff3509f9ba48 SHA512 d239919a42f5107de255cc8de0737bbf57798f949f6845cad13da2fa30ded05ad07319b6294d19fe866ea0d533b3a30ba0f064a9c1091ac39ace6d9998f0f5df
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
new file mode 100644
index 000000000000..ad1160f14a79
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ sed -i -e 's:which:echo:' test/test.sh || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ bash test/test.sh || die "Test failed with ${EPYTHON}"
+}