summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-21 16:03:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-21 16:03:06 +0200
commite87be63b38adf3f4af72bbc80b99b6e12cdadc66 (patch)
tree3e90ba72db9c51c46d16377ef7d09347d4ccd15d /dev-python/python-docs
parentdev-python/python-docs: Remove 3.6* (diff)
downloadgentoo-e87be63b38adf3f4af72bbc80b99b6e12cdadc66.tar.gz
gentoo-e87be63b38adf3f4af72bbc80b99b6e12cdadc66.tar.bz2
gentoo-e87be63b38adf3f4af72bbc80b99b6e12cdadc66.zip
dev-python/python-docs: Bump to 3.7.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.7.13.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index e0034f807a36..e14c41c2a843 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -1,4 +1,5 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.7.11-docs-html.tar.bz2 6294193 BLAKE2B 3fe4794770e81ac92c75d3fe3d717770011d3ee5d98bc0ea67049450427b01924ff10ee41ef04932e4885b08f808bf0e1b8d2b09ead2b28303a25d2a9cc8db56 SHA512 c2e354df460b20cbcf49cde56a93070033dc8364f6678bcab62ffd66dbe9803447d5169c033486331351c2cc1dc7140879297e0ad1ce35c6788c94ad3555b283
+DIST python-3.7.13-docs-html.tar.bz2 6289395 BLAKE2B d59299c681beaa32e56c06b5662960351bb33050b0c097c82c791d930671b653dbaaedce083232d26e08f022dea0a53f7d5c940ee9bc626a94f3c392ee052042 SHA512 a55b43d90f6677e89870001c88106250b695a02ec01832954cce17e1291d259e8440d379ad91f7e0ed1ac3aa1380da28c3a75f29609b881a8f2bad6bf8f79189
DIST python-3.8.11-docs-html.tar.bz2 6603016 BLAKE2B 8488fdef3fce83c71140d4fec328a0564993b95a6d00307da3ace1c3c4447b0edf99e514cdb224cb06df14228748a7ba9355525a5c8afcc4bd4e27ba20530210 SHA512 8fb51867d2e0af1b4f6e39d24241ef5b8955f9f8bada31c4ee096e4148b0313d10eecb4dee3b6af4bef6ffb3e4e871465cad8d05b5974719936f110cc96fb792
DIST python-3.9.6-docs-html.tar.bz2 6848664 BLAKE2B d5e84fc69928e304898120b172629cd724043fff26237908f2adfb13c9ffa11701a87bcd7091eeeee4ef5b2ade12c29781ea26554a7f4fc13fd28efe765b48cf SHA512 b9aa734e9616253278febc5f668ecb6f1d43bc824f84c92e3c13007441388d21e27edd4cb30c463739a271ffcbd8581d6d4573cfe693dca78623762bcdd5bf20
diff --git a/dev-python/python-docs/python-docs-3.7.13.ebuild b/dev-python/python-docs/python-docs-3.7.13.ebuild
new file mode 100644
index 000000000000..0d66370bcd05
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.7.13.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}