summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 22:46:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 22:55:41 +0100
commitd62f06257cb1a15cd66f545b9d49fc76aa06a139 (patch)
tree201bf260f5415105fa53927883afa1f8867e3312 /dev-python/reportlab
parentdev-python/pygments: Bump to 2.11.0 (diff)
downloadgentoo-d62f06257cb1a15cd66f545b9d49fc76aa06a139.tar.gz
gentoo-d62f06257cb1a15cd66f545b9d49fc76aa06a139.tar.bz2
gentoo-d62f06257cb1a15cd66f545b9d49fc76aa06a139.zip
dev-python/reportlab: Bump to 3.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.6.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index a3bc1e24e39f..3d086e057d76 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,3 +1,4 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-3.6.2.tar.gz 4501397 BLAKE2B 725b1142b54f2968d01f788949b9bd4a9208353710724bb7e647be5652b4bb01c37d344db1975f906e83c1265b9dd294fbbfbbb5c1960d25503a255ea32269de SHA512 5a8f22c50bbfcd1e76671e3337df5a740f6451ae42795288c0a0855167d0369543983e895317f1f6cbd14231bc664cea62e5a3b8ccd99775c423074b8c347b68
DIST reportlab-3.6.3.tar.gz 4502282 BLAKE2B 32f096eaa6526eaa3460f85f85e9e2e3947a4f774cce4306248fabd061e0acce3ffcc711552928ddf7d7d6b0cbb8e6629fbf35cbd15176972e0739cf6fd4751e SHA512 7e2f284a322371aa217ed60b966721b0ea5e2419e76bcc50ade9924e0ce6c3f5f9858500b17457883c41738ce5989624b87d26408a8afb65f737e82884b9c7df
+DIST reportlab-3.6.5.tar.gz 4503259 BLAKE2B a394be1fb12808c31aa452da864103487e7d3f04aa3bb173f104e08ff83601da3c9c985c60b0a7b06d9795f87afbafec5a5d0ce1b615e64d1fd648109313eb04 SHA512 47579a5997f4a2f1fc7f2fb2cba7ca6e27913308926dc1e024a169f6ae52a11d62198c56ab9f0e3aae25a12b6c235fd8d4943f8400e8a9bcec937501aa406d76
diff --git a/dev-python/reportlab/reportlab-3.6.5.ebuild b/dev-python/reportlab/reportlab-3.6.5.ebuild
new file mode 100644
index 000000000000..b7688f2391ae
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.6.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ app-arch/unzip"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests unittest
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+src_configure() {
+ DISTUTILS_ARGS=(
+ --no-download-t1-files
+ --use-system-libart
+ )
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py -v || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}