summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2023-06-28 17:30:56 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2023-06-29 09:47:43 +0300
commit8d3a79ce9688a74a4ca8b861212223794d213dff (patch)
treef7930a2e22b1e42583e45885737943d77c78898e /dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
parentdev-python/sphinx-inline-tabs: new package, add 2023.4.21 (diff)
downloadgentoo-8d3a79ce9688a74a4ca8b861212223794d213dff.tar.gz
gentoo-8d3a79ce9688a74a4ca8b861212223794d213dff.tar.bz2
gentoo-8d3a79ce9688a74a4ca8b861212223794d213dff.zip
dev-python/sphinx-argparse: new package, add 0.4.0
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild')
-rw-r--r--dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
new file mode 100644
index 000000000000..2b28e7ab59e5
--- /dev/null
+++ b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension that automatically documents argparse commands and options"
+HOMEPAGE="https://pypi.org/project/sphinx-argparse/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest