summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 04:46:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 04:53:10 +0200
commit03d762e34f42ba97e74e7f9208860bc9be26fa77 (patch)
treef4f7a8fe48c96aa7dc879943b65ef7293da7f2a5 /dev-python/sphinxcontrib-websupport
parentdev-python/sphinxcontrib-serializinghtml: Bump to 1.1.7 (diff)
downloadgentoo-03d762e34f42ba97e74e7f9208860bc9be26fa77.tar.gz
gentoo-03d762e34f42ba97e74e7f9208860bc9be26fa77.tar.bz2
gentoo-03d762e34f42ba97e74e7f9208860bc9be26fa77.zip
dev-python/sphinxcontrib-websupport: Bump to 1.2.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest1
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index 4bf087c072e5..e564774a1382 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-websupport-1.2.4.gh.tar.gz 599695 BLAKE2B 909fc3dd77377769b6242963c2228a01dae4c73b2c1128094ecb5c113517ddb103498fa8615a0690cc41333778a21ba62a7638e36e3d82ad89c74b76156580a4 SHA512 4b5a382037988079e12e5c022ce0351c953e65dacfee7e3a63852370deddcee083cb65914b0bb9a8dc42481015f33d1ac2b5fea61c676ab947f8b0cbe331d7f6
+DIST sphinxcontrib_websupport-1.2.6.tar.gz 599139 BLAKE2B 661ba75c1a222993b558d2bcad0d76e99083ef8d2006526ac8d4f95228d93cb80f68638ba4e5fa245fd79e9bef13babbfcfb6c6decb1a02dd2e2623f37e88374 SHA512 d3085083132cbd9fcd289aff56a72c44f0ed8803e60996c1542da0ca1eaee7f3f38ddd2c45fc44045206091615cf69bc11bb60fb2f95ab5c6dadc2ef65251155
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.6.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.6.ebuild
new file mode 100644
index 000000000000..9eb63d05a957
--- /dev/null
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-websupport/
+ https://pypi.org/project/sphinxcontrib-websupport/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+# there are additional optional test deps on sqlalchemy and whoosh
+# but they're broken with sqlalchemy-2.0
+# https://github.com/sphinx-doc/sphinxcontrib-websupport/issues/61
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_tests pytest