summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-24 07:58:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-24 08:12:53 +0300
commitf85cfd4727e159ce83a21fbdde0b4325bac40316 (patch)
tree1406173e4eb23aa6669ea4d996d60b85da982343 /dev-python/tox
parentdev-python/stestr: drop 3.2.0 (diff)
downloadgentoo-f85cfd4727e159ce83a21fbdde0b4325bac40316.tar.gz
gentoo-f85cfd4727e159ce83a21fbdde0b4325bac40316.tar.bz2
gentoo-f85cfd4727e159ce83a21fbdde0b4325bac40316.zip
dev-python/tox: drop 3.24.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.24.3.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 935dba5f7e08..f10eb6c02733 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,2 +1 @@
-DIST tox-3.24.3.tar.gz 306285 BLAKE2B 368eaf959533f62b08d6e44929ae327ff25ea6eca25a3f47c7b9945428821bf80ab7e0ab4daea8821b55b9a7a009f30c3d5641812fd444a86577ea0ae83adb7d SHA512 de1c1ccc3a277c617521e77806d1d993a5c19f811016bebc442bfea12c3d40a22bf80b7d11b11744a5ddf705c6e8955f2811f149d413ea8522d94c985ed1f715
DIST tox-3.24.4.tar.gz 306760 BLAKE2B 332c99d021bc3c25549fd95d051baaa1f0dc3aaf776928320826bb7e6bce6444fd5a993e1dbff3a4ebbde9dbb59e30d07eae4b04096294b3a186b130b8312587 SHA512 49e2cb74f119b5cc049d2a64479e56307cea1f36a5586840cca12cb8f4ce8a2ba991cc6142bef7f095a7d32b44f7513f89cce56d89deaff0e12194ceb3da6249
diff --git a/dev-python/tox/tox-3.24.3.ebuild b/dev-python/tox/tox-3.24.3.ebuild
deleted file mode 100644
index 93e2236b0b8d..000000000000
--- a/dev-python/tox/tox-3.24.3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
-SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-# doc disabled because of missing deps in tree
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/filelock[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
- ' pypy3)
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]
- >=dev-python/six-1.14[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
-# TODO: figure out how to make tests work without the package being
-# installed first.
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
- >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local deselect=(
- # broken without Internet
- tests/unit/session/test_provision.py::test_provision_non_canonical_dep
- tests/integration/test_provision_int.py::test_provision_interrupt_child
-
- # expects python2 to exist
- tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
- )
-
- [[ ${EPYTHON} != pypy3 ]] && deselect+=(
- # TODO?
- tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
-
- # broken without tox installed first
- # TODO: why it can't import itself?
- tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
- )
-
- distutils_install_for_testing --via-venv
- epytest --no-network ${deselect[@]/#/--deselect }
-}