summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-19 05:36:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-19 05:51:09 +0200
commitbb5e319f0ffb1aa03f5cbb5d5305a51426a1de99 (patch)
tree84e9dadd05113c8fa604c1712302f424ca7f17f3 /dev-python
parentdev-python/Faker: Bump to 19.11.0 (diff)
downloadgentoo-bb5e319f0ffb1aa03f5cbb5d5305a51426a1de99.tar.gz
gentoo-bb5e319f0ffb1aa03f5cbb5d5305a51426a1de99.tar.bz2
gentoo-bb5e319f0ffb1aa03f5cbb5d5305a51426a1de99.zip
dev-python/pytest-plus: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-plus/Manifest1
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.6.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
index 06ba69815958..76c9e9e1e851 100644
--- a/dev-python/pytest-plus/Manifest
+++ b/dev-python/pytest-plus/Manifest
@@ -1,2 +1,3 @@
DIST pytest-plus-0.4.0.tar.gz 9987 BLAKE2B 11b8f17630601f52ebae11b7a660c8d97b4c9f1699096a376c162952a03b9f1b580ead6ac0b040b15c267eec1123bffe07d128eb00aec7414e996275ebc4c4e3 SHA512 4f4258853280cac8e03c0477763fd588d2b3cf11e7746d2b8e7d3cf5774b845412bc8779d74d232e4b3473470c39753dc788ac09faf8e8b7c9fee22d7164bab7
DIST pytest-plus-0.5.0.tar.gz 11444 BLAKE2B f42a7d9abc934635414959263a85399ccdf5377eb58790339d816a8ed8b3962ce11f088e0e074163c6ea9498ae07cbb9422586cbfad572200f1fa628f1b9620f SHA512 02417b2b02ec44d505ea8b6a4217c55b88d1b1383ee36c51b4480824816eb57513b63da36b86004a777ebbbca462bdf40ac3b18331010c10ca6d6259c837f705
+DIST pytest-plus-0.6.0.tar.gz 12795 BLAKE2B 6e618f29e679cf1c71018ab4993606add89a4e3fe47a78b3cb4a17908c2bb0192646108918786183b330016a8e8d5458e87900d8bf4b9b61e90d3e24feab43a8 SHA512 7798a4e53a4ca95b24f9039accea2657746982370cd99f5d34d5dceccc08640214241f1e81f3e354f03782f013bf1b375a4e16a69d23e211948232eca678f98d
diff --git a/dev-python/pytest-plus/pytest-plus-0.6.0.ebuild b/dev-python/pytest-plus/pytest-plus-0.6.0.ebuild
new file mode 100644
index 000000000000..0b918725bd74
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-plus/
+ https://pypi.org/project/pytest-plus/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest