summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/compass-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/compass-core')
-rw-r--r--dev-ruby/compass-core/Manifest2
-rw-r--r--dev-ruby/compass-core/compass-core-1.0.1.ebuild27
-rw-r--r--dev-ruby/compass-core/compass-core-1.0.3-r1.ebuild27
-rw-r--r--dev-ruby/compass-core/metadata.xml13
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/compass-core/Manifest b/dev-ruby/compass-core/Manifest
new file mode 100644
index 000000000000..b2ba21013940
--- /dev/null
+++ b/dev-ruby/compass-core/Manifest
@@ -0,0 +1,2 @@
+DIST compass-core-1.0.1.gem 137728 SHA256 fd07ea734e56113670fd8ecceac143b09a2034dae0b3d11b16326983e5ab0b7e SHA512 ddac9dbbf35981cf71cf3abab80ebe516194e099dbaf9f7f9a3056b2b74df8486a47dcdfeec19252241aac4f575b1f36a78670c9ab125a29871b5025607de28b WHIRLPOOL 163249be0bd648f396f61b2d42aeba80c5c8e54b76d951adf94344d10fe7e659ec478dfa5f8eb97089ec82babb3532f7a8cec923d2cc4ec33062b5d5648db734
+DIST compass-core-1.0.3.gem 137728 SHA256 6ac8bb4cabb5bf80d1a7febbacfd35c1aa83e91a7a511637668dffda38be5a79 SHA512 90ee9fbd2266fc3e437162c8920710e4885446333c8d4b5ae22c652c7572b93ce3071574fa74f432b0036795865f92c888a6d648ee20bf5618cf58fb7b2b1dd1 WHIRLPOOL 8f987a575eb931dfb4a39748f5c12e72422c434868db226ab524937fa37b397a7eea8217b084d4a0117e24b14d1c1d002f5ea02ddb503d7d1155066f0ae4dfa1
diff --git a/dev-ruby/compass-core/compass-core-1.0.1.ebuild b/dev-ruby/compass-core/compass-core-1.0.1.ebuild
new file mode 100644
index 000000000000..94e3bf9c268a
--- /dev/null
+++ b/dev-ruby/compass-core/compass-core-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data stylesheets templates"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Compass Stylesheet Authoring Framework"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.0
+ >=dev-ruby/sass-3.3.0 <dev-ruby/sass-3.5
+"
diff --git a/dev-ruby/compass-core/compass-core-1.0.3-r1.ebuild b/dev-ruby/compass-core/compass-core-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..f4f09a276db3
--- /dev/null
+++ b/dev-ruby/compass-core/compass-core-1.0.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data stylesheets templates VERSION"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Compass Stylesheet Authoring Framework"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.0
+ >=dev-ruby/sass-3.3.0 <dev-ruby/sass-3.5
+"
diff --git a/dev-ruby/compass-core/metadata.xml b/dev-ruby/compass-core/metadata.xml
new file mode 100644
index 000000000000..ba11df1021de
--- /dev/null
+++ b/dev-ruby/compass-core/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury (vikraman)</name>
+ </maintainer>
+ <longdescription lang="en">
+ Compass is a Sass-based Stylesheet Framework that streamlines the
+ creation and maintenance of CSS.
+ </longdescription>
+</pkgmetadata>