summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-27 08:15:26 +0200
committerHans de Graaff <graaff@gentoo.org>2023-03-27 09:37:02 +0200
commite401c2ea5c28b7bad14594ccb96451e54658b517 (patch)
treedbbd9515a20279d07a948d991307f2d712021b84 /dev-ruby/rbnacl/rbnacl-7.1.1-r1.ebuild
parentdev-ruby/rotp: enable ruby32 (diff)
downloadgentoo-e401c2ea5c28b7bad14594ccb96451e54658b517.tar.gz
gentoo-e401c2ea5c28b7bad14594ccb96451e54658b517.tar.bz2
gentoo-e401c2ea5c28b7bad14594ccb96451e54658b517.zip
dev-ruby/rbnacl: update EAPI 7 -> 8, add ruby32
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rbnacl/rbnacl-7.1.1-r1.ebuild')
-rw-r--r--dev-ruby/rbnacl/rbnacl-7.1.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rbnacl/rbnacl-7.1.1-r1.ebuild b/dev-ruby/rbnacl/rbnacl-7.1.1-r1.ebuild
new file mode 100644
index 000000000000..a991bed06b6d
--- /dev/null
+++ b/dev-ruby/rbnacl/rbnacl-7.1.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
+HOMEPAGE="https://github.com/RubyCrypto/rbnacl"
+
+LICENSE="MIT"
+SLOT="6"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-libs/libsodium"
+DEPEND+=" test? ( dev-libs/libsodium )"
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/bundler/ s:^:#:' \
+ -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb
+}