summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-08 18:59:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-08 18:59:03 +0100
commitdbca25f70470eb3997f3f6ed9bcbb0ce8d8b114f (patch)
treeeec976d06c8126499502155020e3d799ca7be6f4 /dev-tex/xcolor/xcolor-2.12.ebuild
parentdev-tex/pgf: Add pgfsys-luatex.def file from Norbert Preining on the TeX Liv... (diff)
downloadgentoo-dbca25f70470eb3997f3f6ed9bcbb0ce8d8b114f.tar.gz
gentoo-dbca25f70470eb3997f3f6ed9bcbb0ce8d8b114f.tar.bz2
gentoo-dbca25f70470eb3997f3f6ed9bcbb0ce8d8b114f.zip
dev-tex/xcolor: Bump to 2.12
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-tex/xcolor/xcolor-2.12.ebuild')
-rw-r--r--dev-tex/xcolor/xcolor-2.12.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-tex/xcolor/xcolor-2.12.ebuild b/dev-tex/xcolor/xcolor-2.12.ebuild
new file mode 100644
index 000000000000..7ef1a07364be
--- /dev/null
+++ b/dev-tex/xcolor/xcolor-2.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package
+
+DESCRIPTION="xcolor -- easy driver-independent access to colors"
+HOMEPAGE="http://www.ukern.de/tex/xcolor.html"
+SRC_URI="http://www.ukern.de/tex/xcolor/ctan/${P//[.-]/}.zip"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-texlive/texlive-latex"
+
+DEPEND="${RDEPEND}
+ doc? (
+ dev-texlive/texlive-pstricks
+ dev-texlive/texlive-latexextra
+ )
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_install() {
+ export VARTEXFONTS="${T}/fonts"
+
+ latex-package_src_install || die
+
+ dodoc README ChangeLog
+}