summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-30 17:32:38 +0100
committerSam James <sam@gentoo.org>2022-08-30 17:33:20 +0100
commit54fec07e295015109b12f59526938847b9fcbca2 (patch)
treeacf2ef0989b5773dcb8237857b715bab16430f36 /dev-util/cvise
parentdev-python/regex: Stabilize 2022.7.25 sparc, #867463 (diff)
downloadgentoo-54fec07e295015109b12f59526938847b9fcbca2.tar.gz
gentoo-54fec07e295015109b12f59526938847b9fcbca2.tar.bz2
gentoo-54fec07e295015109b12f59526938847b9fcbca2.zip
dev-util/cvise: drop -Werror, respect CFLAGS
Closes: https://bugs.gentoo.org/867424 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/cvise')
-rw-r--r--dev-util/cvise/cvise-2.5.0-r1.ebuild (renamed from dev-util/cvise/cvise-2.5.0.ebuild)4
-rw-r--r--dev-util/cvise/files/cvise-2.5.0-no-werror-cflags.patch34
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/cvise/cvise-2.5.0.ebuild b/dev-util/cvise/cvise-2.5.0-r1.ebuild
index 05efec46a120..ed819e732b93 100644
--- a/dev-util/cvise/cvise-2.5.0.ebuild
+++ b/dev-util/cvise/cvise-2.5.0-r1.ebuild
@@ -51,6 +51,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.0-no-werror-cflags.patch
+)
+
llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}
diff --git a/dev-util/cvise/files/cvise-2.5.0-no-werror-cflags.patch b/dev-util/cvise/files/cvise-2.5.0-no-werror-cflags.patch
new file mode 100644
index 000000000000..b00b524cb2a4
--- /dev/null
+++ b/dev-util/cvise/files/cvise-2.5.0-no-werror-cflags.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/867424
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -146,13 +146,13 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
+ OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+ # XXX figure out how to get "-std=c++14 -fno-rtti" from LLVM. That's how we
+ # get those options in the Automake path...
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror -Wno-error=maybe-uninitialized")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -fno-rtti -fno-strict-aliasing -Wall -Wextra -Wno-unused-parameter -Werror -Wno-error=maybe-uninitialized")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-error=maybe-uninitialized")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -fno-rtti -fno-strict-aliasing -Wall -Wextra -Wno-unused-parameter -Wno-error=maybe-uninitialized")
+ if(SUPPORTS_FVISIBILITY_INLINES_HIDDEN_FLAG)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
+ endif()
+- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3")
+- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELEASE} -O3")
++ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
++ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELEASE}")
+ endif()
+
+ ###############################################################################
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 261a0fb..cbaebc3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -151,8 +151,6 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
+ if(SUPPORTS_FVISIBILITY_INLINES_HIDDEN_FLAG)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
+ endif()
+- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
+- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELEASE}")
+ endif()
+
+ ###############################################################################