summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-25 19:30:49 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-25 19:33:18 -0700
commit45730573642c5e9809c0109613636c14dff568ce (patch)
tree5f940255cb09b77041f0a7c05d83d538dfaadfa7 /dev-util/gcovr
parentdev-python/PyUtilib: New package (diff)
downloadgentoo-45730573642c5e9809c0109613636c14dff568ce.tar.gz
gentoo-45730573642c5e9809c0109613636c14dff568ce.tar.bz2
gentoo-45730573642c5e9809c0109613636c14dff568ce.zip
dev-util/gcovr: Version bump to 4.1
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/gcovr')
-rw-r--r--dev-util/gcovr/gcovr-4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/gcovr/gcovr-4.1.ebuild b/dev-util/gcovr/gcovr-4.1.ebuild
new file mode 100644
index 000000000000..0c6dfe433055
--- /dev/null
+++ b/dev-util/gcovr/gcovr-4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python script for summarizing gcov data"
+HOMEPAGE="https://github.com/gcovr/gcovr"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# a bunch of "unknown module" failures
+RESTRICT="test"
+
+python_test() {
+ mkdir "${T}/bin" || die
+ printf -- "#!/bin/bash\nexec PYTHONPATH=\"%s\" python -c 'import gcovr.__main__; gcovr.__main__.main()' -- \"${@}\"" \
+ "${BUILD_DIR}/lib" \
+ > "${T}/bin/gcovr"
+
+ chmod 755 "${T}/bin/gcovr" || die
+
+ PATH="${T}/bin:${PATH}" ${EPYTHON} -m pytest -vv || die
+}