summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-23 00:25:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-23 00:25:17 +0200
commit900c2951babebf0b4f983e1b3098c0a13166a38c (patch)
treee1ec3697f1295be6b7966cf40aadbaac23083f6e /dev-util/strace/strace-9999.ebuild
parentdev-util/strace: Bump to version 5.1 (diff)
downloadgentoo-900c2951babebf0b4f983e1b3098c0a13166a38c.tar.gz
gentoo-900c2951babebf0b4f983e1b3098c0a13166a38c.tar.bz2
gentoo-900c2951babebf0b4f983e1b3098c0a13166a38c.zip
dev-util/strace: Synced live ebuild.
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/strace/strace-9999.ebuild')
-rw-r--r--dev-util/strace/strace-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index e4f979cf0519..db378889c0d5 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
else
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
@@ -78,7 +78,7 @@ src_configure() {
}
src_test() {
- if has usersandbox $FEATURES ; then
+ if has usersandbox ${FEATURES} ; then
ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
return 0
fi
@@ -88,6 +88,8 @@ src_test() {
src_install() {
default
- use perl || rm "${ED%/}"/usr/bin/strace-graph
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/strace-graph || die
+ fi
dodoc CREDITS
}