summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-06 02:57:52 +0100
committerSam James <sam@gentoo.org>2023-07-06 02:57:52 +0100
commit89e944eed5e50d90cf7802d345c97c2de1016999 (patch)
tree646bbc3b34db327a730f3fde83d02587d528f5f8 /dev-util
parentmedia-video/openshot: add 3.1.1 (diff)
downloadgentoo-89e944eed5e50d90cf7802d345c97c2de1016999.tar.gz
gentoo-89e944eed5e50d90cf7802d345c97c2de1016999.tar.bz2
gentoo-89e944eed5e50d90cf7802d345c97c2de1016999.zip
dev-util/global: add 6.6.10
Closes: https://bugs.gentoo.org/763039 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/global/Manifest1
-rw-r--r--dev-util/global/global-6.6.10.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-util/global/Manifest b/dev-util/global/Manifest
index 40b667bfa42e..859a5626f707 100644
--- a/dev-util/global/Manifest
+++ b/dev-util/global/Manifest
@@ -1 +1,2 @@
+DIST global-6.6.10.tar.gz 2999863 BLAKE2B 496bac144c935893b29e23bbb1fa4583a5d6d0ab1b8cd818ff592d7259bb6fa832d79666703f2ac179b5fd39095fd922b8861ad73879c5bac299f9b785797c0b SHA512 babbba6a8dc701b401a12d9961cb7510983e44c7f80836d6d0da165fd0d8cc695e20b7c241526839aef2a70c8bbf97727d910ff17c37751ba3438267139b45d1
DIST global-6.6.4.tar.gz 2988969 BLAKE2B 784087537094d27c10d1f2bc992e799c35ab6ce3b86e041c31279e6954b203e80676b3158ba95e7957456b75a213d70998aae9047836cd4d388212236f05a081 SHA512 cb4ed451d3aaf47c4c59cdc3f74c97d3171108177d4846b5dac843589710e66d87c9d7bbe080c3770329e8e40105ac52dcafb4609257347593cca4d94711f483
diff --git a/dev-util/global/global-6.6.10.ebuild b/dev-util/global/global-6.6.10.ebuild
new file mode 100644
index 000000000000..41abd9d57503
--- /dev/null
+++ b/dev-util/global/global-6.6.10.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit autotools elisp-common python-single-r1
+
+DESCRIPTION="Tag system to find an object location in various sources"
+HOMEPAGE="https://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc emacs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libltdl
+ dev-db/sqlite
+ sys-libs/ncurses
+ $(python_gen_cond_dep '
+ dev-python/pygments[${PYTHON_USEDEP}]
+ ')
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-text/texi2html
+ sys-apps/texinfo
+ )
+"
+
+SITEFILE="50gtags-gentoo.el"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.2.9-tinfo.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-python-interpreter="${PYTHON}"
+ --with-sqlite3 # avoid using bundled copy
+ $(use_with emacs lispdir "${SITELISP}/${PN}")
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi || die
+ texi2html -o doc/global.html doc/global.texi || die
+ fi
+
+ if use emacs; then
+ elisp-compile *.el
+ fi
+
+ emake
+}
+
+src_install() {
+ default
+
+ rm -rf "${ED}"/var/lib || die
+
+ insinto /etc
+ doins gtags.conf
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use doc; then
+ # doc/global.pdf is generated if tex executable (e.g. /usr/bin/tex) is available.
+ [[ -f doc/global.pdf ]] && DOCS+=( doc/global.pdf )
+ fi
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}