summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-07 13:37:54 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-07 13:39:15 +0200
commitff5e1768b15d524caa94f64db29bc0d8b9cd6afe (patch)
tree8f01ca9a49aaff7c575aab1b630bbc53a65ec0df /dev-util
parentdev-python/python-slugify: enable py3.12 (diff)
downloadgentoo-ff5e1768b15d524caa94f64db29bc0d8b9cd6afe.tar.gz
gentoo-ff5e1768b15d524caa94f64db29bc0d8b9cd6afe.tar.bz2
gentoo-ff5e1768b15d524caa94f64db29bc0d8b9cd6afe.zip
dev-util/cookiecutter: add 2.2.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cookiecutter/Manifest1
-rw-r--r--dev-util/cookiecutter/cookiecutter-2.2.0.ebuild52
-rw-r--r--dev-util/cookiecutter/metadata.xml2
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-util/cookiecutter/Manifest b/dev-util/cookiecutter/Manifest
index 4f587fc644cd..e59e9ea83a03 100644
--- a/dev-util/cookiecutter/Manifest
+++ b/dev-util/cookiecutter/Manifest
@@ -1,3 +1,4 @@
DIST cookiecutter-1.7.3.tar.gz 253444 BLAKE2B 92ae74768c909ab8e2ae97ad87921ae0cbf24c417ab6985ac10eacd913981ee7756843e2588936174d3c04ecfa7a62077a6d4a323fdfa6d1872f3c84d943cbcb SHA512 a7dd7993ba40a084a719d553afbb8035f26976f38a3e8ee373c8074db64eac6bd7b711eca8cedbfd1050fc057a0b45409af4d59ff3bde57b344317dbee56f10b
DIST cookiecutter-2.0.2.tar.gz 260840 BLAKE2B 008c4dceb1218ba7ead3846d24fc77253988a1fedfee929f30b4d2a63ee6ead9f2733e58e84f2d29840a5885b6655bb7d554664cec4175f49bd333b493c0f36d SHA512 0bd490e3f7067fbe87aeff35255ccac0d05d723c6505345856284612752a65e4e35a8e5fb4410f900d42e3998e68d7aa8bec402686404336dedbc456fd4cda49
DIST cookiecutter-2.1.1.tar.gz 263100 BLAKE2B 6f054cc5e03328db3198443fe1f99bbef285fe03a1f9bf588b4b80d2314da10f6c998221cf6c41bff9c7fdc3c92680290468dfb070ade4a868ab80f941c1f6a4 SHA512 7833bfc0e6d2d32060e099a97a4477114c2e6f9b09f951c4a5519153fd7c1f9659c22596e443392272f4a6f80eabb2a346417bac56ea7ea4108fc6b36fc0072c
+DIST cookiecutter-2.2.0.tar.gz 270467 BLAKE2B 4bb308448e4e400902ac7b0af7a496065e5cb9a27959616bcb100451decc111d526b35158d96139e65ba6a8f1f71fc0bde2653cbfad1779c43ab9e703acb7253 SHA512 bd09e01e761dbbfd9f8c6f271aedda504edae1bc1e118906ea05984a38d262c7c7680210c6310c94bcdd19da4c68d74ce48849a01b88b5904dd6565309459cce
diff --git a/dev-util/cookiecutter/cookiecutter-2.2.0.ebuild b/dev-util/cookiecutter/cookiecutter-2.2.0.ebuild
new file mode 100644
index 000000000000..f4dd1e02e7f0
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-2.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/cookiecutter/cookiecutter"
+SRC_URI="https://github.com/cookiecutter/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/arrow[${PYTHON_USEDEP}]
+ >=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-9.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ <dev-python/jinja-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}/test_cli-1.7.2.patch"
+)
+
+distutils_enable_tests pytest
+# TODO: Package sphinx-click
+# distutils_enable_sphinx docs \
+# dev-python/sphinx-rtd-theme \
+# dev-python/recommonmark
+
+python_test() {
+ epytest -o addopts=
+}
diff --git a/dev-util/cookiecutter/metadata.xml b/dev-util/cookiecutter/metadata.xml
index 61e2dc802064..ddb58f880b7b 100644
--- a/dev-util/cookiecutter/metadata.xml
+++ b/dev-util/cookiecutter/metadata.xml
@@ -11,6 +11,6 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="github">audreyr/cookiecutter</remote-id>
+ <remote-id type="github">cookiecutter/cookiecutter</remote-id>
</upstream>
</pkgmetadata>