summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-action/abuse
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-action/abuse')
-rw-r--r--games-action/abuse/abuse-0.9_p20181213-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-action/abuse/abuse-0.9_p20181213-r1.ebuild b/games-action/abuse/abuse-0.9_p20181213-r1.ebuild
index 5117d81dff90..caf6ee16cf2e 100644
--- a/games-action/abuse/abuse-0.9_p20181213-r1.ebuild
+++ b/games-action/abuse/abuse-0.9_p20181213-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
COMMIT="42b6acd19af00689e8f34355e3b13323d8ea3f79"
DATA_PV="0.8"
@@ -26,7 +26,7 @@ S="${WORKDIR}/${PN}-${COMMIT}"
src_prepare() {
ln -snf ../../${PN}-${DATA_PV}/data/{music,sfx} data/ || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -35,11 +35,11 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doicon -s 32 doc/${PN}.png
make_desktop_entry abuse Abuse
}