summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-06 21:12:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-07 09:53:59 +0200
commita98fc176b8e977eedb3501cf0617948c22547310 (patch)
tree8cc2b8bc25d8a8e6525b49e531e9a1299553f0a6 /kde-plasma/kwallet-pam
parentdev-python/pebble: Bump to 4.5.2 (diff)
downloadgentoo-a98fc176b8e977eedb3501cf0617948c22547310.tar.gz
gentoo-a98fc176b8e977eedb3501cf0617948c22547310.tar.bz2
gentoo-a98fc176b8e977eedb3501cf0617948c22547310.zip
kde-plasma: Add KDE Plasma 5.18.5
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.18.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 6cf3b5280785..ea697926af4e 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.17.5.tar.xz 19712 BLAKE2B 2166498cddaabf55ea77312b96e863fe666afffe976507aa4f1c1421f7182c8db195d55b7462d3355acadb4cf2008792983712ec286811d22348ccdcc6cbfbbc SHA512 3a15ad62cb59aca1165c3159572669e5a44a2f1bb6aee51937b4d970a4eb901f7fbee74ed874ad20d65e3adb4009e143954dda1ee31ccd223c3a1b3208da6436
DIST kwallet-pam-5.18.4.1.tar.xz 19840 BLAKE2B d5d6879b6fe71098eb92ca34a1c11424d590c7ff000f8b476b666fdd2ff09767aa3489ea9038d92375073815a42a73d08984851823f798099ae874f563a4536b SHA512 7be9fe57d29e3f03344cd477902c3d5ce9c19223645d1536502dbe2d6f74c0aede4435c997e6f9880bd3b44b865ee95579e64f73485dc6b6305143da44877b67
+DIST kwallet-pam-5.18.5.tar.xz 19800 BLAKE2B 695fb89d1a54bfc44b06bee4881ae357a42c82b6506a6ed7966c30bb28137ee379ac1beb9391982c15ac63e95c0a1bbba2e0950ee89e050a2ceaf296b98958d4 SHA512 050b3ca66f3b078bb7bccb4a3b7750787bf22d18af60972969f83141b99eac4441fa08d48022278cfe28c8f96f7a1d9ca346f155d8ddbdb60b17bc9c142521cc
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.18.5.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.18.5.ebuild
new file mode 100644
index 000000000000..849263d4d766
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.18.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}