summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2023-07-02 23:06:55 +0200
committerSam James <sam@gentoo.org>2023-07-16 19:39:41 +0100
commitd6af608ad3b3519f7cbd4e4158afbb7c979d887c (patch)
tree71ec4b7978c06d69d8befe9f026632da0304da7f /media-gfx
parentmedia-gfx/blender: Bump 3.6.0 (diff)
downloadgentoo-d6af608ad3b3519f7cbd4e4158afbb7c979d887c.tar.gz
gentoo-d6af608ad3b3519f7cbd4e4158afbb7c979d887c.tar.bz2
gentoo-d6af608ad3b3519f7cbd4e4158afbb7c979d887c.zip
media-gfx/blender: Disable OSL support per default
Because llvm 16 is now marked stable, there is a very high chance of users having Blender sefault on startup because of missmatched llvm libraries. Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/blender/blender-3.3.6-r1.ebuild10
-rw-r--r--media-gfx/blender/blender-3.3.8.ebuild10
-rw-r--r--media-gfx/blender/blender-3.4.1-r3.ebuild10
-rw-r--r--media-gfx/blender/blender-3.5.1-r1.ebuild10
-rw-r--r--media-gfx/blender/blender-3.6.0.ebuild10
-rw-r--r--media-gfx/blender/blender-9999.ebuild10
6 files changed, 54 insertions, 6 deletions
diff --git a/media-gfx/blender/blender-3.3.6-r1.ebuild b/media-gfx/blender/blender-3.3.6-r1.ebuild
index 0ba992b8d937..04f62d303e24 100644
--- a/media-gfx/blender/blender-3.3.6-r1.ebuild
+++ b/media-gfx/blender/blender-3.3.6-r1.ebuild
@@ -28,7 +28,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb \
alembic collada +color-management cuda +cycles \
debug doc +embree +ffmpeg +fftw +gmp headless jack jemalloc jpeg2k \
man +nanovdb ndof nls openal +oidn +openimageio +openmp +opensubdiv \
- +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile \
+ +openvdb optix osl +pdf +potrace +pugixml pulseaudio sdl +sndfile \
test +tiff valgrind"
RESTRICT="!test? ( test ) test"
@@ -383,6 +383,14 @@ pkg_postinst() {
elog "changing the 'Temporary Files' directory in Blender preferences."
elog
+ if use osl; then
+ ewarn ""
+ ewarn "OSL is know to cause runtime segfaults if Mesa has been linked to"
+ ewarn "an other LLVM version than what OSL is linked to."
+ ewarn "See https://bugs.gentoo.org/880671 for more details"
+ ewarn ""
+ fi
+
if ! use python_single_target_python3_10; then
elog "You are building Blender with a newer python version than"
elog "supported by this version upstream."
diff --git a/media-gfx/blender/blender-3.3.8.ebuild b/media-gfx/blender/blender-3.3.8.ebuild
index 650e8d12291a..4d537708342b 100644
--- a/media-gfx/blender/blender-3.3.8.ebuild
+++ b/media-gfx/blender/blender-3.3.8.ebuild
@@ -28,7 +28,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb \
alembic collada +color-management cuda +cycles \
debug doc +embree +ffmpeg +fftw +gmp headless jack jemalloc jpeg2k \
man +nanovdb ndof nls openal +oidn +openimageio +openmp +opensubdiv \
- +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile \
+ +openvdb optix osl +pdf +potrace +pugixml pulseaudio sdl +sndfile \
test +tiff valgrind"
RESTRICT="!test? ( test ) test"
@@ -383,6 +383,14 @@ pkg_postinst() {
elog "changing the 'Temporary Files' directory in Blender preferences."
elog
+ if use osl; then
+ ewarn ""
+ ewarn "OSL is know to cause runtime segfaults if Mesa has been linked to"
+ ewarn "an other LLVM version than what OSL is linked to."
+ ewarn "See https://bugs.gentoo.org/880671 for more details"
+ ewarn ""
+ fi
+
if ! use python_single_target_python3_10; then
elog "You are building Blender with a newer python version than"
elog "supported by this version upstream."
diff --git a/media-gfx/blender/blender-3.4.1-r3.ebuild b/media-gfx/blender/blender-3.4.1-r3.ebuild
index 78ad154c35e2..4c94d176f10c 100644
--- a/media-gfx/blender/blender-3.4.1-r3.ebuild
+++ b/media-gfx/blender/blender-3.4.1-r3.ebuild
@@ -28,7 +28,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb \
alembic collada +color-management cuda +cycles \
debug doc +embree +ffmpeg +fftw +gmp jack jemalloc jpeg2k \
man +nanovdb ndof nls openal +oidn +openimageio +openmp +opensubdiv \
- +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile \
+ +openvdb optix osl +pdf +potrace +pugixml pulseaudio sdl +sndfile \
test +tiff valgrind wayland X"
RESTRICT="!test? ( test )"
@@ -397,6 +397,14 @@ pkg_postinst() {
elog "changing the 'Temporary Files' directory in Blender preferences."
elog
+ if use osl; then
+ ewarn ""
+ ewarn "OSL is know to cause runtime segfaults if Mesa has been linked to"
+ ewarn "an other LLVM version than what OSL is linked to."
+ ewarn "See https://bugs.gentoo.org/880671 for more details"
+ ewarn ""
+ fi
+
if ! use python_single_target_python3_10; then
elog "You are building Blender with a newer python version than"
elog "supported by this version upstream."
diff --git a/media-gfx/blender/blender-3.5.1-r1.ebuild b/media-gfx/blender/blender-3.5.1-r1.ebuild
index 28e3907b79b1..3a41bd4ce801 100644
--- a/media-gfx/blender/blender-3.5.1-r1.ebuild
+++ b/media-gfx/blender/blender-3.5.1-r1.ebuild
@@ -29,7 +29,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb
alembic collada +color-management cuda +cycles cycles-bin-kernels
debug doc +embree +ffmpeg +fftw +gmp jack jemalloc jpeg2k
man +nanovdb ndof nls openal +oidn +openmp +openpgl +opensubdiv
- +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl
+ +openvdb optix osl +pdf +potrace +pugixml pulseaudio sdl
+sndfile test +tiff valgrind wayland X"
RESTRICT="!test? ( test )"
@@ -401,6 +401,14 @@ pkg_postinst() {
elog "changing the 'Temporary Files' directory in Blender preferences."
elog
+ if use osl; then
+ ewarn ""
+ ewarn "OSL is know to cause runtime segfaults if Mesa has been linked to"
+ ewarn "an other LLVM version than what OSL is linked to."
+ ewarn "See https://bugs.gentoo.org/880671 for more details"
+ ewarn ""
+ fi
+
if ! use python_single_target_python3_10; then
elog "You are building Blender with a newer python version than"
elog "supported by this version upstream."
diff --git a/media-gfx/blender/blender-3.6.0.ebuild b/media-gfx/blender/blender-3.6.0.ebuild
index 28e3907b79b1..3a41bd4ce801 100644
--- a/media-gfx/blender/blender-3.6.0.ebuild
+++ b/media-gfx/blender/blender-3.6.0.ebuild
@@ -29,7 +29,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb
alembic collada +color-management cuda +cycles cycles-bin-kernels
debug doc +embree +ffmpeg +fftw +gmp jack jemalloc jpeg2k
man +nanovdb ndof nls openal +oidn +openmp +openpgl +opensubdiv
- +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl
+ +openvdb optix osl +pdf +potrace +pugixml pulseaudio sdl
+sndfile test +tiff valgrind wayland X"
RESTRICT="!test? ( test )"
@@ -401,6 +401,14 @@ pkg_postinst() {
elog "changing the 'Temporary Files' directory in Blender preferences."
elog
+ if use osl; then
+ ewarn ""
+ ewarn "OSL is know to cause runtime segfaults if Mesa has been linked to"
+ ewarn "an other LLVM version than what OSL is linked to."
+ ewarn "See https://bugs.gentoo.org/880671 for more details"
+ ewarn ""
+ fi
+
if ! use python_single_target_python3_10; then
elog "You are building Blender with a newer python version than"
elog "supported by this version upstream."
diff --git a/media-gfx/blender/blender-9999.ebuild b/media-gfx/blender/blender-9999.ebuild
index e5b31060c53c..d6db9dfe90a8 100644
--- a/media-gfx/blender/blender-9999.ebuild
+++ b/media-gfx/blender/blender-9999.ebuild
@@ -29,7 +29,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb
alembic collada +color-management cuda +cycles cycles-bin-kernels
debug doc +embree +ffmpeg +fftw +gmp jack jemalloc jpeg2k
man +nanovdb ndof nls openal +oidn +openmp +openpgl +opensubdiv
- +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl
+ +openvdb optix osl +pdf +potrace +pugixml pulseaudio sdl
+sndfile test +tiff valgrind wayland X"
RESTRICT="!test? ( test )"
@@ -401,6 +401,14 @@ pkg_postinst() {
elog "changing the 'Temporary Files' directory in Blender preferences."
elog
+ if use osl; then
+ ewarn ""
+ ewarn "OSL is know to cause runtime segfaults if Mesa has been linked to"
+ ewarn "an other LLVM version than what OSL is linked to."
+ ewarn "See https://bugs.gentoo.org/880671 for more details"
+ ewarn ""
+ fi
+
if ! use python_single_target_python3_10; then
elog "You are building Blender with a newer python version than"
elog "supported by this version upstream."