summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-03-20 09:17:18 +0000
committerMatthew Smith <matthew@gentoo.org>2022-03-20 09:21:49 +0000
commite5c639662a44ea4187cb0dd0115abb207ca0aac5 (patch)
tree982ceb44c5a8f726592bc49a0c0b1cab6c7056a9 /net-im
parentsys-kernel/linux-headers: drop versions (diff)
downloadgentoo-e5c639662a44ea4187cb0dd0115abb207ca0aac5.tar.gz
gentoo-e5c639662a44ea4187cb0dd0115abb207ca0aac5.tar.bz2
gentoo-e5c639662a44ea4187cb0dd0115abb207ca0aac5.zip
net-im/cawbird: init at 1.5
This package is intended to replace net-im/corebird. Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/cawbird/Manifest1
-rw-r--r--net-im/cawbird/cawbird-1.5.ebuild64
-rw-r--r--net-im/cawbird/metadata.xml11
3 files changed, 76 insertions, 0 deletions
diff --git a/net-im/cawbird/Manifest b/net-im/cawbird/Manifest
new file mode 100644
index 000000000000..8c822e3f91a8
--- /dev/null
+++ b/net-im/cawbird/Manifest
@@ -0,0 +1 @@
+DIST cawbird-1.5.tar.gz 675527 BLAKE2B d94bf61faba01fc1159fabbf0da24ab49a697112ccd5bb631133c21f52ffe29e9ede214c9eccf553cbbb039b08e487467e4ecc56d0e0ef63f68d4c23d39414aa SHA512 917480ac79606a1ab572f0837fd48e100bbb6d70ad3551a8d86486843d9bfb0e4814c75c56ff0e2aa41fd7d32a614bbff4e6121831b3da7da7614fb5a0d3f6e1
diff --git a/net-im/cawbird/cawbird-1.5.ebuild b/net-im/cawbird/cawbird-1.5.ebuild
new file mode 100644
index 000000000000..9d9fb0d01d35
--- /dev/null
+++ b/net-im/cawbird/cawbird-1.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Twitter client"
+HOMEPAGE="https://ibboard.co.uk/cawbird/ https://github.com/IBBoard/cawbird"
+SRC_URI="https://github.com/IBBoard/cawbird/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}
+
+LICENSE="CC-BY-3.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gstreamer spell"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/json-glib
+ net-libs/liboauth
+ net-libs/libsoup:2.4
+ net-libs/rest:0.7
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+ gstreamer? ( media-libs/gstreamer:1.0 )
+ spell? ( app-text/gspell:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ # these keys are taken from the readme of cawbird
+ -Dconsumer_key_base64='VmY5dG9yRFcyWk93MzJEZmhVdEk5Y3NMOA=='
+ -Dconsumer_secret_base64='MThCRXIxbWRESDQ2Y0podzVtVU13SGUyVGlCRXhPb3BFRHhGYlB6ZkpybG5GdXZaSjI='
+ -Dexamples=false
+ $(meson_use spell spellcheck)
+ $(meson_use gstreamer video)
+ -Dx11=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/net-im/cawbird/metadata.xml b/net-im/cawbird/metadata.xml
new file mode 100644
index 000000000000..d1905ebb02b4
--- /dev/null
+++ b/net-im/cawbird/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">IBBoard/cawbird</remote-id>
+</upstream>
+</pkgmetadata>