summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 21:17:04 +0000
committerSam James <sam@gentoo.org>2022-07-02 21:17:16 +0000
commit7e853c664f4abbe5e1e82abca97f41e193c6c624 (patch)
tree5cc8f42bb6ba16cb2fd58e648f9091f76e1ef39c /net-proxy
parentsci-libs/caffe2: add support for nnpack (diff)
downloadgentoo-7e853c664f4abbe5e1e82abca97f41e193c6c624.tar.gz
gentoo-7e853c664f4abbe5e1e82abca97f41e193c6c624.tar.bz2
gentoo-7e853c664f4abbe5e1e82abca97f41e193c6c624.zip
net-proxy/havp: fix build with GCC 12
Closes: https://bugs.gentoo.org/855575 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/havp/files/havp-0.92a-gcc12-time.patch11
-rw-r--r--net-proxy/havp/havp-0.92a-r3.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/net-proxy/havp/files/havp-0.92a-gcc12-time.patch b/net-proxy/havp/files/havp-0.92a-gcc12-time.patch
new file mode 100644
index 000000000000..0faf90dca3a6
--- /dev/null
+++ b/net-proxy/havp/files/havp-0.92a-gcc12-time.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/855575
+--- a/havp/logfile.cpp
++++ b/havp/logfile.cpp
+@@ -30,6 +30,7 @@
+ #include <map>
+ #include <cstdlib>
+ #include <cstring>
++#include <ctime>
+
+ #define LOGSTRINGLENGTH 1000
+
diff --git a/net-proxy/havp/havp-0.92a-r3.ebuild b/net-proxy/havp/havp-0.92a-r3.ebuild
index 682e96119730..ff931e27294d 100644
--- a/net-proxy/havp/havp-0.92a-r3.ebuild
+++ b/net-proxy/havp/havp-0.92a-r3.ebuild
@@ -22,8 +22,9 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}"/havp-0.92a-run.patch
+ "${FILESDIR}"/${P}-run.patch
"${FILESDIR}"/${P}-pkg-config-libclamav.patch
+ "${FILESDIR}"/${P}-gcc12-time.patch
)
src_prepare() {