summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
commit128c4b0b6c73f994174bf351d311ed021adbc6f7 (patch)
treeb29ea0b846a53af1bc54ded701368dd2ff5f638a /sci-chemistry
parentwww-apps/prowlarr: drop 1.0.0.2171 (diff)
downloadgentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.gz
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.bz2
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.zip
*/*: make mycmakeargs local
Closes: https://github.com/gentoo/gentoo/pull/28947 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.7.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.5.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.6.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.9999.ebuild6
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.3.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.4.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2023.9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2023_rc1.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild4
15 files changed, 39 insertions, 39 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
index 255810902b42..29c88f0d70a6 100644
--- a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -147,7 +147,7 @@ src_configure() {
cuda=( "-DGMX_GPU=ON" )
local opencl=( "-DGMX_USE_OPENCL=OFF" )
use opencl && opencl=( "-DGMX_USE_OPENCL=ON" ) cuda=( "-DGMX_GPU=ON" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -162,7 +162,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
index bf9f493d1163..7f9f30390239 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -158,7 +158,7 @@ src_configure() {
cuda=( "-DGMX_GPU=ON" )
local opencl=( "-DGMX_USE_OPENCL=OFF" )
use opencl && opencl=( "-DGMX_USE_OPENCL=ON" ) cuda=( "-DGMX_GPU=ON" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -174,7 +174,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
index ea9f998593a4..ceafc20dcc7c 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -160,7 +160,7 @@ src_configure() {
cuda=( "-DGMX_GPU=ON" )
local opencl=( "-DGMX_USE_OPENCL=OFF" )
use opencl && opencl=( "-DGMX_USE_OPENCL=ON" ) cuda=( "-DGMX_GPU=ON" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -176,7 +176,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
index a1a975ee8107..4dba54bef4ab 100644
--- a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -231,7 +231,7 @@ src_configure() {
cuda=( "-DGMX_GPU=ON" )
local opencl=( "-DGMX_USE_OPENCL=OFF" )
use opencl && opencl=( "-DGMX_USE_OPENCL=ON" ) cuda=( "-DGMX_GPU=ON" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -249,7 +249,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2020.7.ebuild b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
index afbf991e279f..7e8fc98af66e 100644
--- a/sci-chemistry/gromacs/gromacs-2020.7.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -231,7 +231,7 @@ src_configure() {
cuda=( "-DGMX_GPU=ON" )
local opencl=( "-DGMX_USE_OPENCL=OFF" )
use opencl && opencl=( "-DGMX_USE_OPENCL=ON" ) cuda=( "-DGMX_GPU=ON" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -249,7 +249,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
index f55212f3bdc7..fb8e9270106c 100644
--- a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -237,7 +237,7 @@ src_configure() {
local gpu=( "-DGMX_GPU=OFF" )
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -254,7 +254,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2021.5.ebuild b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
index 0a8e8fdc1642..61808242def9 100644
--- a/sci-chemistry/gromacs/gromacs-2021.5.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -237,7 +237,7 @@ src_configure() {
local gpu=( "-DGMX_GPU=OFF" )
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -254,7 +254,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2021.6.ebuild b/sci-chemistry/gromacs/gromacs-2021.6.ebuild
index 0614696b9b09..4c4b095e5f91 100644
--- a/sci-chemistry/gromacs/gromacs-2021.6.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -237,7 +237,7 @@ src_configure() {
local gpu=( "-DGMX_GPU=OFF" )
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -254,7 +254,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
index 31f880174588..ece941e30ed3 100644
--- a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -235,7 +235,7 @@ src_configure() {
local gpu=( "-DGMX_GPU=OFF" )
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -252,7 +252,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON
diff --git a/sci-chemistry/gromacs/gromacs-2022.3.ebuild b/sci-chemistry/gromacs/gromacs-2022.3.ebuild
index d0f55aca4bc1..306bd72ec9bb 100644
--- a/sci-chemistry/gromacs/gromacs-2022.3.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -245,7 +245,7 @@ src_configure() {
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
[[ ${x} = "float" ]] && use clang-cuda && gpu=( "-DGMX_GPU=CUDA" "-DGMX_CLANG_CUDA=ON" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=$(usex mpi)
-DGMX_THREAD_MPI=$(usex threads)
diff --git a/sci-chemistry/gromacs/gromacs-2022.4.ebuild b/sci-chemistry/gromacs/gromacs-2022.4.ebuild
index 72ac3b19bbcd..15a7139387d8 100644
--- a/sci-chemistry/gromacs/gromacs-2022.4.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -245,7 +245,7 @@ src_configure() {
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
[[ ${x} = "float" ]] && use clang-cuda && gpu=( "-DGMX_GPU=CUDA" "-DGMX_CLANG_CUDA=ON" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=$(usex mpi)
-DGMX_THREAD_MPI=$(usex threads)
diff --git a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
index 72ac3b19bbcd..15a7139387d8 100644
--- a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -245,7 +245,7 @@ src_configure() {
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
[[ ${x} = "float" ]] && use clang-cuda && gpu=( "-DGMX_GPU=CUDA" "-DGMX_CLANG_CUDA=ON" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=$(usex mpi)
-DGMX_THREAD_MPI=$(usex threads)
diff --git a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
index f2f127f13d21..df489bdf84db 100644
--- a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -243,7 +243,7 @@ src_configure() {
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
[[ ${x} = "float" ]] && use clang-cuda && gpu=( "-DGMX_GPU=CUDA" "-DGMX_CLANG_CUDA=ON" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=$(usex mpi)
-DGMX_THREAD_MPI=$(usex threads)
diff --git a/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild b/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild
index f2f127f13d21..df489bdf84db 100644
--- a/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -243,7 +243,7 @@ src_configure() {
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
[[ ${x} = "float" ]] && use clang-cuda && gpu=( "-DGMX_GPU=CUDA" "-DGMX_CLANG_CUDA=ON" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=$(usex mpi)
-DGMX_THREAD_MPI=$(usex threads)
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index f2f127f13d21..df489bdf84db 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -243,7 +243,7 @@ src_configure() {
[[ ${x} = "float" ]] && use cuda && gpu=( "-DGMX_GPU=CUDA" )
[[ ${x} = "float" ]] && use clang-cuda && gpu=( "-DGMX_GPU=CUDA" "-DGMX_CLANG_CUDA=ON" )
use opencl && gpu=( "-DGMX_GPU=OPENCL" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=$(usex mpi)
-DGMX_THREAD_MPI=$(usex threads)