summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:08:02 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:08:02 +0200
commit0f81a83cc3011f51ff66d1a7ee416f40f1b05ecb (patch)
treee01a07e3bd59f38f8663543aabcef67f5b3855ab /sci-geosciences/geopy/geopy-2.2.0.ebuild
parentdev-python/pyphen: Require pyproj2setuppy with dict install fix (diff)
downloadgentoo-0f81a83cc3011f51ff66d1a7ee416f40f1b05ecb.tar.gz
gentoo-0f81a83cc3011f51ff66d1a7ee416f40f1b05ecb.tar.bz2
gentoo-0f81a83cc3011f51ff66d1a7ee416f40f1b05ecb.zip
sci-geosciences/geopy: geocoding library for python
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-geosciences/geopy/geopy-2.2.0.ebuild')
-rw-r--r--sci-geosciences/geopy/geopy-2.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-geosciences/geopy/geopy-2.2.0.ebuild b/sci-geosciences/geopy/geopy-2.2.0.ebuild
new file mode 100644
index 000000000000..f06c131bf150
--- /dev/null
+++ b/sci-geosciences/geopy/geopy-2.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for several popular geocoding web services"
+HOMEPAGE="https://github.com/geopy/geopy"
+SRC_URI="${HOMEPAGE}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Need geocoding service to test
+RESTRICT="test"
+
+RDEPEND="sci-geosciences/GeographicLib[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""