summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-26 23:59:00 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-27 00:02:23 +0100
commitc48eb0296dd717296e8725d2c5c34bb31d89616c (patch)
tree442de7944510d497cc504cb03d238ea7b5f9b4f0 /sci-geosciences
parentprofiles: Mask games-fps/serious-sam-tse for removal (diff)
downloadgentoo-c48eb0296dd717296e8725d2c5c34bb31d89616c.tar.gz
gentoo-c48eb0296dd717296e8725d2c5c34bb31d89616c.tar.bz2
gentoo-c48eb0296dd717296e8725d2c5c34bb31d89616c.zip
sci-geosciences/folium: add 0.15.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/folium/Manifest1
-rw-r--r--sci-geosciences/folium/files/folium-0.15.1-gentoo.patch11
-rw-r--r--sci-geosciences/folium/folium-0.15.1.ebuild47
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-geosciences/folium/Manifest b/sci-geosciences/folium/Manifest
index cbfd689235eb..4e16f055c870 100644
--- a/sci-geosciences/folium/Manifest
+++ b/sci-geosciences/folium/Manifest
@@ -1 +1,2 @@
DIST folium-0.14.0.tar.gz 20121396 BLAKE2B 8b6014444e4992ae6828f844d197f475d0050567ebaf630b58015ed08274793d3837903cb7a4d7f28da14bb47d8d65a6d09e097b7765fc0a115224aec521854a SHA512 2aec27c731a4d2c835172d0e29d4ddbce745ec5665e168f392fd9693d9b267f734b4a7275ae202fccba17501320414abefd332376bc917fa0fba72bcffade43e
+DIST folium-0.15.1.tar.gz 8400799 BLAKE2B c01c4029882aed5c1390be05a358c6c9e321e1562573bb1ae7246b462bc9183c21ba7631ca6b9a0e51311375f90f06bac5651c28505fa0d73c65942267ab2ce4 SHA512 fdc0b7bb0c864337b10d92e60090382d67d29e9158bb92c22ae53e749612d88427db95d34990c8895a04017ca1a5870330c6d9da3abb94e19ff6141b94f503c0
diff --git a/sci-geosciences/folium/files/folium-0.15.1-gentoo.patch b/sci-geosciences/folium/files/folium-0.15.1-gentoo.patch
new file mode 100644
index 000000000000..852644b1820c
--- /dev/null
+++ b/sci-geosciences/folium/files/folium-0.15.1-gentoo.patch
@@ -0,0 +1,11 @@
+--- a/setup.cfg 2022-11-06 09:51:58.139499881 +0100
++++ b/setup.cfg 2022-11-06 09:52:15.064237829 +0100
+@@ -1,6 +1,6 @@
+ [metadata]
+-description-file = README.md
+-license_file = LICENSE.txt
++description_file = README.md
++license_files = LICENSE.txt
+
+ [bdist_wheel]
+ universal = 1
diff --git a/sci-geosciences/folium/folium-0.15.1.ebuild b/sci-geosciences/folium/folium-0.15.1.ebuild
new file mode 100644
index 000000000000..80320ba16aa6
--- /dev/null
+++ b/sci-geosciences/folium/folium-0.15.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python Data, Leaflet.js Maps"
+HOMEPAGE="https://github.com/python-visualization/folium"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.1-scm.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+RDEPEND="sci-libs/branca[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r tests/selenium || die # require chromedriver
+ rm tests/test_folium.py || die # require geopandas
+ rm tests/test_raster_layers.py || die # require xyzservices
+ rm tests/plugins/test_time_slider_choropleth.py || die # require geopandas
+ rm tests/test_repr.py || die # require geckodriver
+ default
+}
+
+python_test() {
+ epytest -m 'not web'
+}