summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-06-08 14:36:23 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-06-08 14:36:23 -0500
commitf9e43f12b9961f034decc9093149b23d661c11bc (patch)
treeaf8b79604707725abe297f66547576c567b50c79 /sys-apps
parentdev-python/qdarkstyle: enable py3.11 (diff)
downloadgentoo-f9e43f12b9961f034decc9093149b23d661c11bc.tar.gz
gentoo-f9e43f12b9961f034decc9093149b23d661c11bc.tar.bz2
gentoo-f9e43f12b9961f034decc9093149b23d661c11bc.zip
sys-apps/openrc: remove unused code
Version 0.44.x should try to install urandom if seedrng is in the boot runlevel and we are downgrading. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/openrc-0.44.10.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-apps/openrc/openrc-0.44.10.ebuild b/sys-apps/openrc/openrc-0.44.10.ebuild
index e7337a132e40..c4028fe6262e 100644
--- a/sys-apps/openrc/openrc-0.44.10.ebuild
+++ b/sys-apps/openrc/openrc-0.44.10.ebuild
@@ -155,4 +155,15 @@ pkg_postinst() {
ewarn "without networking."
ewarn
fi
+
+ # added to handle downgrading from 0.45 (2022-06-08)
+ for v in ${REPLACING_VERSIONS}; do
+ [[ -x $(type rc-update) ]] || continue
+ if ver_test $v -gt 0.44.10; then
+ if rc-update show boot | grep -q seedrng; then
+ rc-update del seedrng boot
+ rc-update add urandom boot
+ fi
+ fi
+ done
}