summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-10-20 10:30:38 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-10-20 11:17:06 -0700
commit9cfd030087f4881e2603337d6a4b6a9574d69a23 (patch)
treea6ff70b7835ab64cd806a50c1a17ee76229594fb /virtual
parentdev-lang/rust: re-add 1.63.0-r1 for riscv only (diff)
downloadgentoo-9cfd030087f4881e2603337d6a4b6a9574d69a23.tar.gz
gentoo-9cfd030087f4881e2603337d6a4b6a9574d69a23.tar.bz2
gentoo-9cfd030087f4881e2603337d6a4b6a9574d69a23.zip
virtual/rust: re-add 1.63.0 for riscv only
This partially reverts commit cbb188bf659435e9aff0cd41cbdafb80bc9ec295. Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rust/rust-1.63.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.63.0.ebuild b/virtual/rust/rust-1.63.0.ebuild
new file mode 100644
index 000000000000..1f4093c8a7a3
--- /dev/null
+++ b/virtual/rust/rust-1.63.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~riscv"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"