summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-04-19 00:22:02 +0300
committerSam James <sam@gentoo.org>2022-05-15 00:11:59 +0000
commitc3b7b1ba8b8f185e3c308f01506d4037006a5ee1 (patch)
tree21242ac8b3546ad1ca1cecdb257c6e96a3bf2313 /x11-libs
parentlxqt-base/liblxqt: add version 1.1.0 (diff)
downloadgentoo-c3b7b1ba8b8f185e3c308f01506d4037006a5ee1.tar.gz
gentoo-c3b7b1ba8b8f185e3c308f01506d4037006a5ee1.tar.bz2
gentoo-c3b7b1ba8b8f185e3c308f01506d4037006a5ee1.zip
x11-libs/libfm-qt: add version 1.1.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfm-qt/Manifest1
-rw-r--r--x11-libs/libfm-qt/libfm-qt-1.1.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-libs/libfm-qt/Manifest b/x11-libs/libfm-qt/Manifest
index 24ee9c531076..b3d31dbd36b4 100644
--- a/x11-libs/libfm-qt/Manifest
+++ b/x11-libs/libfm-qt/Manifest
@@ -1,2 +1,3 @@
DIST libfm-qt-0.17.1.tar.xz 363052 BLAKE2B 5931a5f06f0d085aedf0b178efe4f47ccc90d6e99dfa88955d692736d0dbc4fb8ebc9c5b834547b473b84ce815bb7e1e2e991fee38f390e7ff85c8a3effe8f26 SHA512 1e1781a01446f381625361a50f77422827e7ac5ab6039b4246369e2281edf78d3ccba866fa472667bcbb6737c44ebc350cb30a0055fc84d1f5d7e1c83e1241c1
DIST libfm-qt-1.0.0.tar.xz 379492 BLAKE2B 28a111434deb0ece8ab54d7d558c13e3f5d66b8e2b18bfb5d84601c10b6cd822c0bea794b1e959d95ca2427272d8aa008ef7fe49056228288472397c72241e6d SHA512 8609709b00a67273e4cb3ca18ad695df172ff3cac2ed70d48e5f607c20a4d4507598b500957bf197bffa65db4ad5843f3fd477a56868c95507a594542f24b5b4
+DIST libfm-qt-1.1.0.tar.xz 383280 BLAKE2B f01b8d2b21bee05c265f55d6b1c71644001bd668a03d8c4994a4e0fde2f07e53014d3b079d818b7a66cd25f8c9141fa980d0cdb9d3b8e4a66eb3b1521c46690b SHA512 6717bc3fd3a2795389071e4dbfba2e73f3abfeafce8a583f99b3281e60347430db48246eb29796c5b7647b35b064824e90fc3a286547288798a1c6da3a3f5137
diff --git a/x11-libs/libfm-qt/libfm-qt-1.1.0.ebuild b/x11-libs/libfm-qt/libfm-qt-1.1.0.ebuild
new file mode 100644
index 000000000000..b91728959387
--- /dev/null
+++ b/x11-libs/libfm-qt/libfm-qt-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Library for Building File Managers"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD GPL-2+ LGPL-2.1+"
+SLOT="0/7"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.11.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5=
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ >=lxde-base/menu-cache-1.1.0:=
+ media-libs/libexif
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}