summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-11-10 20:16:24 +0000
committerSam James <sam@gentoo.org>2024-11-26 03:14:36 +0000
commit4dbe992f0df8f29723cab7e95185bfddceca05f9 (patch)
tree43d2677650efae5a71a49b35616f09474d13dd1f /x11-themes
parentmate-extra/mate-system-monitor: add 1.28.1 (diff)
downloadgentoo-4dbe992f0df8f29723cab7e95185bfddceca05f9.tar.gz
gentoo-4dbe992f0df8f29723cab7e95185bfddceca05f9.tar.bz2
gentoo-4dbe992f0df8f29723cab7e95185bfddceca05f9.zip
x11-themes/mate-themes: add 3.22.26
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/mate-themes/Manifest1
-rw-r--r--x11-themes/mate-themes/mate-themes-3.22.26.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/mate-themes/Manifest b/x11-themes/mate-themes/Manifest
index 93847e3bb40b..5497a1bec94a 100644
--- a/x11-themes/mate-themes/Manifest
+++ b/x11-themes/mate-themes/Manifest
@@ -1 +1,2 @@
DIST mate-themes-3.22.24.tar.xz 5689444 BLAKE2B 7f245a0373eee36f17dea8d1e1b1c59fad78f0c19372014caee2fbfe89ee250c554d369c082152f1531fb9b59a79ba5896d50074f118076039cc2e077bca8883 SHA512 a92b78c3899b9ad159dbc1ee310939c300c45c203a9976bc83a76e49beb79b4fb551bfaa26c638d54da7630639a61df802113466844a6664e83ea6ab68c7dbc5
+DIST mate-themes-3.22.26.tar.xz 6145568 BLAKE2B e66d397be02df8f91b972e5073397019627508f90f8100e25601d93a77f72e368b57e1c664d72972f097f880c301c534c0cc06479637df39d16b8c9382b192d2 SHA512 fdccbdb3692d17b7b3060b2eb6cda1237ad270fdc20e34c67dc1012327526088141705c623564eaa86e8b1d0793cca63cd8f59cfcc9ff38dc3a73f89adadd6d9
diff --git a/x11-themes/mate-themes/mate-themes-3.22.26.ebuild b/x11-themes/mate-themes/mate-themes-3.22.26.ebuild
new file mode 100644
index 000000000000..fa121bd8c466
--- /dev/null
+++ b/x11-themes/mate-themes/mate-themes-3.22.26.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+MATE_GTK_V="$(ver_cut 1-2)"
+
+HOMEPAGE="https://mate-desktop.org"
+DESCRIPTION="A set of MATE themes, with sets for users with limited or low vision"
+SRC_URI="https://pub.mate-desktop.org/releases/themes/${MATE_GTK_V}/${P}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0 GPL-3+ LGPL-2.1+ LGPL-3"
+SLOT="0/${MATE_GTK_V}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+RESTRICT="binchecks strip"
+
+RDEPEND="
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-2:2
+"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.8:*
+ >=dev-build/autoconf-2.53
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Cleanup files from user's system as license is already accepted in package.licence
+ # the default install phase chokes if they're not available to install.
+ find "${ED}"/usr/share/themes -type f -name COPYING -delete || die
+}