summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/ngtcp2/ngtcp2-1.5.0.ebuild3
-rw-r--r--net-libs/ngtcp2/ngtcp2-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild b/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild
index d36fb26328c9..2d57c3b7c864 100644
--- a/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-1.5.0.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
LICENSE="MIT"
SLOT="0/0"
IUSE="+gnutls openssl +ssl static-libs test"
-REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) ) test? ( static-libs )"
BDEPEND="virtual/pkgconfig"
RDEPEND="
@@ -43,6 +43,7 @@ multilib_src_configure() {
-DENABLE_WOLFSSL=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
-DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ -DBUILD_TESTING=$(usex test)
)
cmake_src_configure
}
diff --git a/net-libs/ngtcp2/ngtcp2-9999.ebuild b/net-libs/ngtcp2/ngtcp2-9999.ebuild
index 1f15a2e28c49..c72e046deae8 100644
--- a/net-libs/ngtcp2/ngtcp2-9999.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
LICENSE="MIT"
SLOT="0/0"
IUSE="+gnutls openssl +ssl static-libs test"
-REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) ) test? ( static-libs )"
BDEPEND="virtual/pkgconfig"
RDEPEND="
@@ -43,6 +43,7 @@ multilib_src_configure() {
-DENABLE_WOLFSSL=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
-DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ -DBUILD_TESTING=$(usex test)
)
cmake_src_configure
}