summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/kramdown-syntax-coderay/Manifest1
-rw-r--r--dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild21
-rw-r--r--dev-ruby/kramdown-syntax-coderay/metadata.xml8
3 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/kramdown-syntax-coderay/Manifest b/dev-ruby/kramdown-syntax-coderay/Manifest
new file mode 100644
index 000000000000..1642437f57c0
--- /dev/null
+++ b/dev-ruby/kramdown-syntax-coderay/Manifest
@@ -0,0 +1 @@
+DIST kramdown-syntax-coderay-1.0.1.gem 7680 BLAKE2B 66385a651b4a03980984385d09a0076388bcf5f8506ab19267bd75824300c431630280ab5dc9bed41310e69938d2b1d9d42ecef2feace7a5b184c84e9614fdb1 SHA512 bd3e1d919cba7a797f43706f5b8543817654b10abb6c7eed56d99c3a8b75e91f7896db0c04ab999df9f39d21d7dfbc7a39a290e39129812fa5ed3cc8d674abad
diff --git a/dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild b/dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild
new file mode 100644
index 000000000000..32cb7421eb3b
--- /dev/null
+++ b/dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Uses coderay to highlight code blocks/spans"
+HOMEPAGE="https://github.com/kramdown/syntax-coderay"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/coderay-1.1:0 dev-ruby/kramdown:2"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/kramdown-syntax-coderay/metadata.xml b/dev-ruby/kramdown-syntax-coderay/metadata.xml
new file mode 100644
index 000000000000..eb1e47f2edfb
--- /dev/null
+++ b/dev-ruby/kramdown-syntax-coderay/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>