summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-table-extra')
-rw-r--r--app-i18n/fcitx-table-extra/Manifest3
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.3.ebuild27
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.6.ebuild27
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.7.ebuild27
-rw-r--r--app-i18n/fcitx-table-extra/metadata.xml5
5 files changed, 89 insertions, 0 deletions
diff --git a/app-i18n/fcitx-table-extra/Manifest b/app-i18n/fcitx-table-extra/Manifest
new file mode 100644
index 000000000000..621aa9742fe7
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/Manifest
@@ -0,0 +1,3 @@
+DIST fcitx-table-extra-0.3.3.tar.xz 3350592 SHA256 ae2bbf9146dfdeafb6220c9a738ddc1f0437da2c5f2da0d578ba4970bc74767d SHA512 ea100ba7bfc558395b678390bb787b15f674c13140ab22b5a9ef423e5114399633d24ec322904fd61d8f3613058744d08f615d4330ed948aad9dcff09818e36f WHIRLPOOL 10a61ea0aac14e9b55902276557c5b5daba17c14a3101d4e4e1384c8922c89dbfe96b1ac543e9ad3408f0951ecd7869a8c4c0d36d168129b2f78d611a0f70158
+DIST fcitx-table-extra-0.3.6.tar.xz 3694520 SHA256 9f80984d23622b90a7d5fbf439f54d7d46f6e2f640618b00079214f50a62a233 SHA512 3970fd9fb14afef5bc55fcfb8234c12951cf88a8ead9be1575ba3100d08f83f23c923093722380ca9c066d6a3fa065bd51f176b09815b0c85f13d8351a004304 WHIRLPOOL b296eb3198cbf578c4b556942591aee9a9998e3677776a8a6d5a4b80cc3e360d4b6cd784e88d5eb3714879d1ec1231d13e2ad9cca50439470362ae1a9473963a
+DIST fcitx-table-extra-0.3.7.tar.xz 3704164 SHA256 8933570ecd803a4f4fe932c983004e669d81b2f08c3bcaa532151545a42e659e SHA512 628eb7d2b09a3383ab92460dc8c2bc86771482cc84bdce847a394ee595423642dff29a39ccf31f56ea8de833f25e9d42952b55b754dd234d0831b5de5431d16a WHIRLPOOL 2744d91154d51d2388192ce313f4be2e839d5dc33e20622a68208e8e4f155883aedb7b4828e619a1a81e21ea4f893fb6806e59ebed66d842259477a7b4127122
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.3.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.3.ebuild
new file mode 100644
index 000000000000..eb85808c7ad2
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Extra tables for Fcitx, including Boshiamy, Zhengma, Cangjie and Quick"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.7[table]"
+DEPEND="${RDEPEND}
+ virtual/libintl"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.6.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.6.ebuild
new file mode 100644
index 000000000000..dca95d4bf52f
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Extra tables for Fcitx, including Boshiamy, Zhengma, Cangjie and Quick"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8[table]"
+DEPEND="${RDEPEND}
+ virtual/libintl"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.7.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.7.ebuild
new file mode 100644
index 000000000000..a62f314d4670
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Extra tables for Fcitx, including Boshiamy, Zhengma, Cangjie and Quick"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8[table]"
+DEPEND="${RDEPEND}
+ virtual/libintl"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-table-extra/metadata.xml b/app-i18n/fcitx-table-extra/metadata.xml
new file mode 100644
index 000000000000..cb36a2fd8c76
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+</pkgmetadata>