summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/opencc/opencc-1.0.5.ebuild')
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
index 3e9033333de3..50bab76e2c03 100644
--- a/app-i18n/opencc/opencc-1.0.5.ebuild
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -5,9 +5,19 @@ EAPI="6"
inherit cmake-utils
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/BYVoid/OpenCC"
+fi
+
DESCRIPTION="Project for conversion between Traditional and Simplified Chinese"
HOMEPAGE="https://github.com/BYVoid/OpenCC"
-SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+fi
LICENSE="Apache-2.0"
SLOT="0/2"
@@ -17,6 +27,10 @@ IUSE="doc"
DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/OpenCC-ver.${PV}"
+fi
+
DOCS=(AUTHORS NEWS.md README.md)
src_configure() {