summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgpiod/libgpiod-1.6.3-r1.ebuild (renamed from dev-libs/libgpiod/libgpiod-1.6.3.ebuild)9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-libs/libgpiod/libgpiod-1.6.3.ebuild b/dev-libs/libgpiod/libgpiod-1.6.3-r1.ebuild
index 8f3fe8c74ec2..a0b6d335709c 100644
--- a/dev-libs/libgpiod/libgpiod-1.6.3.ebuild
+++ b/dev-libs/libgpiod/libgpiod-1.6.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal
+inherit linux-mod multilib-minimal
DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
@@ -20,6 +20,11 @@ RESTRICT="!test? ( test )"
# --enable-bindings-cxx enable C++ bindings [default=no]
# --enable-bindings-python
+pkg_setup() {
+ CONFIG_CHECK="GPIO_CDEV_V1"
+ linux-mod_pkg_setup
+}
+
multilib_src_configure() {
local myconf=(
$(use_enable tools)