summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/googleapis-common-protos')
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0-r1.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0-r1.ebuild
new file mode 100644
index 000000000000..66b5f36534ac
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.56.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="https://pypi.org/project/googleapis-common-protos/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/protobuf-python-3.12.0[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code