summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nose-parameterized/nose-parameterized-0.5.0.ebuild')
-rw-r--r--dev-python/nose-parameterized/nose-parameterized-0.5.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/nose-parameterized/nose-parameterized-0.5.0.ebuild b/dev-python/nose-parameterized/nose-parameterized-0.5.0.ebuild
new file mode 100644
index 000000000000..4db7e64112d0
--- /dev/null
+++ b/dev-python/nose-parameterized/nose-parameterized-0.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parameterized testing with any Python test framework"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}