summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simplegeneric')
-rw-r--r--dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
index f97cf443efee..d719cc5e73b0 100644
--- a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
+++ b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-PYTHON_COMPAT=( python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -16,10 +15,7 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE=""
-DEPEND="
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+DEPEND="app-arch/unzip"
python_test() {
esetup.py test