summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild')
-rw-r--r--dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
index 2b89625c44ca..5f551895c577 100644
--- a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
+++ b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python3_6 pypy3 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -35,6 +35,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/yaml.patch" )
python_test() {
nosetests --with-coverage || die